Results 1 to 3 of 3
  1. #1

    Join Date
    May 2013
    Location
    Long Island, New York
    Posts
    37

    new with questions

    hey guys whats up just picked up a 97 xp800 last week..runs good no problems until today..

    kind of a stupid mistake but long story short i broke the trim rod..but not the metal one, the plastic piece (seen here on the diagram part # 27)


    i was curious how difficult it is to change this and what is involved? if anyone could give me any advice it would be greatly appreciated


  2. #2

    Join Date
    Apr 2013
    Location
    Tampa
    Posts
    70
    +1
    3
    i have one if you want it, pm me with details, very very easy to fix.
    shoot me a text 813 810 0744 for questions, i would be happy to help. but, basically just remove the VTS cover, unbolt the screws holding the VTS motor to the ski, unbolt all the linkage from the back of that rod and it will slide out through the hull. also, make sure you release the clamps holding the accordian seal from that shaft and be careful not to rip it... if its ripped replace it before you put your ski in the water. take it from my

  3. #3

    Join Date
    May 2013
    Location
    Long Island, New York
    Posts
    37
    Quote Originally Posted by brblommel View Post
    i have one if you want it, pm me with details, very very easy to fix.
    shoot me a text 813 810 0744 for questions, i would be happy to help. but, basically just remove the VTS cover, unbolt the screws holding the VTS motor to the ski, unbolt all the linkage from the back of that rod and it will slide out through the hull. also, make sure you release the clamps holding the accordian seal from that shaft and be careful not to rip it... if its ripped replace it before you put your ski in the water. take it from my

    ahh perfect! ill shoot you a text a little later thanks so much.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. new here with questions
    By an07si in forum Kawasaki Projects
    Replies: 3
    Last Post: 05-02-2011, 03:45 PM
  2. New to forum with Question
    By basshawk84 in forum Yamaha PWC Performance (4-stroke)
    Replies: 1
    Last Post: 07-26-2010, 06:13 PM
  3. New guy with questions...
    By MechE in forum 4-Tec Performance
    Replies: 3
    Last Post: 04-15-2010, 01:01 PM
  4. New Owner with questions
    By frbob in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 07-29-2007, 07:23 AM
  5. First Ride With New Skis ??? Questions
    By rickreeves1 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 05-27-2007, 11:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •