Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    Join Date
    Feb 2012
    Location
    Ohio
    Posts
    132
    +1
    7

    Solas Concord Impeller 14/21 (KR-CD-14/21) Mounting Issue (2011 300X)

    I was able to get the original stock Impeller off with no issues. The Impeller tool (Splined Shaft with a 22mm Nut) simply won't fit into the splines of the Solas Impeller. The Solas Impeller threads on just fine tool won't fit to tighten it... Surely wouldn't fit on the splined drive shaft either I suspect. I can't verify the fit on the drive shaft because the JetSki is +250 miles away. The tool did fit just fine in the stock Impeller. Am I missing something or is it time to send it back?!


  2. #2
    brisyl's Avatar
    Join Date
    Feb 2009
    Location
    New Brunswick, Canada
    Posts
    681
    +1
    59
    If the part number on it is really KR-CD-14/21 and it don't fit, there is a problem with the impeller or your tool is just a bit tight, does the tool fit tight in the stock impeller?
    you better try it on the shaft first before returning it.

    Quote Originally Posted by Speed Jones View Post
    I was able to get the original stock Impeller off with no issues. The Impeller tool (Splined Shaft with a 22mm Nut) simply won't fit into the splines of the Solas Impeller. The Solas Impeller threads on just fine tool won't fit to tighten it... Surely wouldn't fit on the splined drive shaft either I suspect. I can't verify the fit on the drive shaft because the JetSki is +250 miles away. The tool did fit just fine in the stock Impeller. Am I missing something or is it time to send it back?!

  3. #3

    Join Date
    Feb 2012
    Location
    Ohio
    Posts
    132
    +1
    7
    The tool fits the stock Impeller perfectly. Not tight, and not loose. I think the splined insert in the Solas Impeller is not right... Just checking on here to see if anyone has seen the same thing, OR heard of this issue. I probably just got a bad one!?!

  4. #4
    Moderator #985 lasportsmn's Avatar
    Join Date
    Oct 2008
    Location
    Pierre Part, Louisiana
    Posts
    4,780
    +1
    358
    Check on the Solas impeller itself and make sure it is stamped with the proper number and that it was not put in the wrong box. If it is the correct impeller and does not fit contack who you got it from and see about getting it returned. I have not had this problem with any of the impellers I have used.

  5. #5
    brisyl's Avatar
    Join Date
    Feb 2009
    Location
    New Brunswick, Canada
    Posts
    681
    +1
    59
    someone else had the same problem a few weeks ago

    http://www.greenhulk.net/forums/showthread.php?t=195445

  6. +1 by:


  7. #6
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    did you try it with the front seal removed?

  8. #7

    Join Date
    Feb 2012
    Location
    Ohio
    Posts
    132
    +1
    7
    Yes, the Splined Shaft Seal on the Stock Impeller was removed prior to removing it from the Pump. The Splined Shaft Seal that comes with the Solas Impeller has not been installed yet. I was planning on waiting to torque the Impeller to specification before installing the Splined Shaft Seal.

  9. #8

    Join Date
    Feb 2012
    Location
    Ohio
    Posts
    132
    +1
    7
    So far I have looked at the thread "Brisyl" noted, and talked to Impros. Although this is aparently not a common problem, it has been seen before. The Impros fella mentioned also seeing this issue on both Skat Trac as well as Solas Impellers. He said he ALWAYS puts a an Impeller Wrench (Tool) in the plines of an Impeller before he ships one out! The Amazon Seller (Powersport Superstore) so far is running me around. My plan at this point is to reinstall the Stock Impeller as there is absolutely nothing wrong with it. Other than getting to look over the Jet Pump condition, this apparently was a complete waste of time, effort, and money........ The lesson here is you don't necessarily get what you pay for, BUT you definitely won't get don't pay for! Vendors like Impros cost more because they do more to ensure customer satisfaction.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Solas Impeller.jpg 
Views:	89 
Size:	53.0 KB 
ID:	302411   Click image for larger version. 

Name:	Stock Impeller.jpg 
Views:	78 
Size:	52.7 KB 
ID:	302412  

  10. #9

    Join Date
    Feb 2012
    Location
    Ohio
    Posts
    132
    +1
    7
    My money, minus the shipping to me has been refunded by Amazon. This vendor (Powersport Superstore) is absolutely worthless! They ran me around for 3 weeks, had me ship the defective Impeller back at my cost, and eventually said "... I apologize for my misunderstanding, the previous e-mails are consistently getting removed and I was not able to reference every single one of them. However, I am at fault for my miscommunication and apologize for bringing further dissatisfaction sir. Once we receive we will be processing a warranty claim with Solas on your behalf and this process can take a couple of weeks...". My advice is STAY AWAY from this vendor. PERIOD!

  11. #10
    kensmith's Avatar
    Join Date
    Mar 2013
    Location
    TX
    Posts
    1,010
    +1
    13
    ATTACH]
    Quote Originally Posted by Speed Jones View Post
    I was able to get the original stock Impeller off with no issues. The Impeller tool (Splined Shaft with a 22mm Nut) simply won't fit into the splines of the Solas Impeller. The Solas Impeller threads on just fine tool won't fit to tighten it... Surely wouldn't fit on the splined drive shaft either I suspect. I can't verify the fit on the drive shaft because the JetSki is +250 miles away. The tool did fit just fine in the stock Impeller. Am I missing something or is it time to send it back?!
    I have a new Solas KC SC that dosent even have a place for there wrench !!!???
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMAG7119.jpg 
Views:	52 
Size:	90.4 KB 
ID:	303779   Click image for larger version. 

Name:	IMAG7117.jpg 
Views:	56 
Size:	75.3 KB 
ID:	303778  

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS FS SOLAS Concord impeller - KX - CD - 16/21
    By MikeR397 in forum General Classifieds
    Replies: 0
    Last Post: 09-17-2016, 03:46 PM
  2. FS 2 14/19 and 1 15/20 Solas Concord Impellers
    By maildude in forum Sea Doo Classifieds
    Replies: 4
    Last Post: 06-06-2011, 11:29 PM
  3. FS New in box! Solas Concord impeller YD-CD-12/18
    By ocjumper in forum Yamaha Classifieds
    Replies: 2
    Last Post: 06-16-2010, 09:05 PM
  4. wtb Solas concord impellers, part # YD-CD-1218
    By maddogSXM in forum Yamaha Classifieds
    Replies: 2
    Last Post: 09-25-2008, 09:56 AM
  5. FS: 14/20 Solas Concord impeller
    By OCFZR in forum Yamaha Classifieds
    Replies: 0
    Last Post: 05-11-2008, 10:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •