Results 1 to 4 of 4
  1. #1

    Ski revs up but doesn't go anywhere - hdtechboomer

    Quote Originally Posted by xlint89 View Post

    Ski revs up but doesn't go anywhere. First check your intake area by the jet pump for debris.

    Next if you have a rubber dampened engine coupler (black) under the plastic cover, look for signs of rubber shavings. Due to age, the driveshaft will slip inside the rubber, and won't transfer power to the impeller.

    Finally inspect the drive shaft splines on both ends for signs of wear (pointed or damaged), and check the engine coupler and impeller splines too. DO NOT put your finger inside them. You may get a nasty metal splinter if they are bad.
    I must say i been trying to find this answer for the longest time.

    I removed the propeller assy, but it wouldnt come out completley, i was trying to inspect the whole shaft. Took the plastic shield off and it was moving when i cranked it over.

    I wanna rebuild this right because i love this piece, and its my first. Back history I hit a MAD wake had to be 4-5 feet in the air, came down on accident with full throttle and as soon as i hit the water no output what so ever.

    Motor sounds great, checked compression best one is at cyl [email protected] 125 cyl [email protected] cyl @110. never checked the compression before the incident but it ran like a beast.

    So new fuel pump, all new hoses (bulk fuel line is okay?) One thing i noticed if it sat for a while i had to take off the air filter and just spray a little fuel to get it going, due to fuel pump issue i am guessing.

    Got the exhaust out, expansion chamber, fuel tank. anything else i should take apart and replace while i have the extra room?

    Really appreciate the info thats on these forums.
    Last edited by K447; 05-30-2013 at 07:33 AM.


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    Welcome

    Which model and year is your Polaris watercraft?

    See my signature links for info on how to remove the jet pump properly, then remove the drive shaft.

  3. #3
    It is a 94 polaris sl 650, I ended up getting it all off. Is it okay to use bulk fuel line? Got the fuel pump coming, driveshaft, coupler, gaskets, seals, oring, bumpers. Anything else i need to know? The propeller splines look great, no need to replace. Looks as if i may have to take the carbs off to do the fuel pump upgrade, so it has correct routing.

  4. #4
    Fink's Avatar
    Join Date
    Mar 2013
    Location
    North East Arkansas
    Posts
    258
    +1
    5
    Quote Originally Posted by hdtechboomer View Post
    It is a 94 polaris sl 650, I ended up getting it all off. Is it okay to use bulk fuel line? Got the fuel pump coming, driveshaft, coupler, gaskets, seals, oring, bumpers. Anything else i need to know? The propeller splines look great, no need to replace. Looks as if i may have to take the carbs off to do the fuel pump upgrade, so it has correct routing.
    Any grade of fuel line can be bought in bulk, so it depends on what grade you are talking about. I recommend USCG - ASE j1257 Type A1, which has a flame retardant outer layer or Type A1 - 16, which is the low permeation version of Type A1. If you are interested I have 25' of the type A1 - 16 that I'll let go for $45 shipped. Shields brand, the good stuff.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. gpr revs up but goes nowhere
    By rich.allen in forum Yamaha PWC Performance (2-stroke)
    Replies: 19
    Last Post: 08-18-2012, 11:05 AM
  2. Help!... 705sl revs but doesn't go?
    By Ron Welch in forum Polaris How To & FAQs
    Replies: 6
    Last Post: 04-22-2012, 01:39 PM
  3. 2004 Yamaha XL700 waverunner-revs up but won't pick up speed
    By novak in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 07-24-2011, 05:51 PM
  4. Motor revs, doesn't go anywhere!
    By lockaby32 in forum Polaris How To & FAQs
    Replies: 10
    Last Post: 07-13-2011, 09:42 AM
  5. Gp1200 Caviatating! Will rev up but go NOWHERE HELP!
    By ktyamaha36 in forum Yamaha How To & FAQs
    Replies: 4
    Last Post: 03-30-2010, 02:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •