Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1

    1994 seadoo bogging

    I just got a 1994 seadoo xp. When I got it it did not run so I took everything off down to the carbs. Then we dropped a little gas in each one and it started to run. I started it a few times before I put it in the water and it started right up. Then when I put it in water it didn't start so I took it to a local shop and they said it was flooded. Then once they fixed it I took it back to the river and got in started it and it ran fine for like a minute then just shut off. Then again I started it and ran it at just little throtle for about 2 minutes and then I started ridin around again and it shut off again. I was far from where I docked so then I started it again an everytime I hit the gas it would start to go then bog out. It did this everytime til I got back to shore by just idling. Then I took the carb off and had it cleaned and put it back on. It still the idle is perfect but as soon as I hit the gas it bogs out. What can I do to stop this?


  2. #2
    mattydipps's Avatar
    Join Date
    Mar 2013
    Location
    Babylon, Long Island
    Posts
    652
    +1
    51
    Quote Originally Posted by Joeeckert View Post
    I just got a 1994 seadoo xp. When I got it it did not run so I took everything off down to the carbs. Then we dropped a little gas in each one and it started to run. I started it a few times before I put it in the water and it started right up. Then when I put it in water it didn't start so I took it to a local shop and they said it was flooded. Then once they fixed it I took it back to the river and got in started it and it ran fine for like a minute then just shut off. Then again I started it and ran it at just little throtle for about 2 minutes and then I started ridin around again and it shut off again. I was far from where I docked so then I started it again an everytime I hit the gas it would start to go then bog out. It did this everytime til I got back to shore by just idling. Then I took the carb off and had it cleaned and put it back on. It still the idle is perfect but as soon as I hit the gas it bogs out. What can I do to stop this?
    still have the grey tempo fuel lines in the ski??

    have you cleaned the fuel selector valve?

  3. #3
    I have grey fuel lines but I thought that that ment they was replaced. Ad no I haven't. I don't know much about these things just learning as I go

  4. #4
    Did you clean the micro filters under the fuel pump and plate?

  5. #5
    I didn't clean the carbs. I had someone do it for me

  6. #6

    Join Date
    Apr 2008
    Location
    plattsburgh ,ny
    Posts
    75
    +1
    1
    You need to check those internal fuel filters, some shops only replace gaskets... and barely do a good job at that!

    Buy yourself a tech book for that model fast!

  7. #7

    Join Date
    Apr 2008
    Location
    plattsburgh ,ny
    Posts
    75
    +1
    1
    Steps: 1) Clean fuel selector switch
    2) replace fuel lines
    3 clean internal fuel filter inside carbs
    4) clean gas tank pick up
    5) check spark plug gap
    6)check fuel mixure

  8. #8
    Well it hasn't ran in a year or two I know that so I'm gonna take it to the river and run it for awhile and see if it will start running right

  9. #9
    Quote Originally Posted by Joeeckert View Post
    Well it hasn't ran in a year or two I know that so I'm gonna take it to the river and run it for awhile and see if it will start running right
    That's the worst thing you can do. It sounds like you have a fuel issue and ignoring it will cost you an engine

  10. #10
    Well I thought it could of been bad gas. I thin its getting to much oil. But it also blows oil at the back but it's dirty brown oil. Well it did do that I don't think it does now. But it would run when you barely pushed the throtle in but when you pushed it in any farther it would bog out unless you feathered and played with it you could get the speed going but eventually it bogged out again.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need Help 1994 Seadoo gtx with no spark
    By Polaris rider 1 in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 09-21-2008, 01:55 PM
  2. 1994 Seadoo Spx Mod.
    By OLDJETSKIMAN in forum 2-Stroke Performance
    Replies: 1
    Last Post: 09-11-2008, 08:55 PM
  3. 1994 Seadoo Spx Mod.
    By OLDJETSKIMAN in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 09-11-2008, 07:10 PM
  4. Fs: 1994 Seadoo Xp
    By camar0 in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 04-29-2008, 06:00 PM
  5. 1994 Seadoo SP WO throttle cuts off
    By Stumpotto in forum 2-Stroke Performance
    Replies: 1
    Last Post: 10-10-2007, 06:55 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •