Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20
  1. #1
    DustMan's Avatar
    Join Date
    May 2010
    Location
    NC
    Posts
    56
    +1
    1

    127 wheel break in

    Do you have to really check the slip after breaking it in. That sure is a lot of trouble to do when your at the lake wanting to ride all day. Just wanting other opinions. Thanks


  2. #2
    Boost-A-Holic's Avatar
    Join Date
    Jul 2012
    Location
    Dallas, Texas, United States
    Posts
    1,173
    +1
    94
    id recommend it.....or if you got a boost gauge use that for reference. If your not makin max boost your slip could be off.

  3. #3
    DustMan's Avatar
    Join Date
    May 2010
    Location
    NC
    Posts
    56
    +1
    1
    That's what I was thinking just wanted others thoughts. Thanks man

  4. #4
    Boost-A-Holic's Avatar
    Join Date
    Jul 2012
    Location
    Dallas, Texas, United States
    Posts
    1,173
    +1
    94
    Quote Originally Posted by DustMan View Post
    That's what I was thinking just wanted others thoughts. Thanks man
    anytime

  5. #5
    AtoMIC_OraNGE greenbullet's Avatar
    Join Date
    Jul 2010
    Location
    Barrie / BuckHORN Ontario
    Posts
    2,509
    +1
    234
    ride the ski.. basically the break in is once the clutchs get hot and start to slip... id recommend 2 hrs at various rpm and then check the slip... that wheel should be set up at around 13lbs slip and will break in at around 11-12 when hot... which 127 wheel are we talking here? arts Etech127?

  6. #6
    DustMan's Avatar
    Join Date
    May 2010
    Location
    NC
    Posts
    56
    +1
    1
    Yeah ET 127. Broke it in today. Set slip and went riding, Man what a ride. List of what I had to what I just put on
    Had riva thru hull, block off, r&d intake, 4" kana, short gutted water box,of course riva washers
    Put on last tuesday, 42's, 15/20R, ET 127, wear ring, boost gauge. Deaad stand still to full throttle it cavatates bad but if I just roll in to it then hammer down it halls the mail. Why is it?

  7. #7
    AtoMIC_OraNGE greenbullet's Avatar
    Join Date
    Jul 2010
    Location
    Barrie / BuckHORN Ontario
    Posts
    2,509
    +1
    234
    Quote Originally Posted by DustMan View Post
    Yeah ET 127. Broke it in today. Set slip and went riding, Man what a ride. List of what I had to what I just put on
    Had riva thru hull, block off, r&d intake, 4" kana, short gutted water box,of course riva washers
    Put on last tuesday, 42's, 15/20R, ET 127, wear ring, boost gauge. Deaad stand still to full throttle it cavatates bad but if I just roll in to it then hammer down it halls the mail. Why is it?
    thats normal... if you said you already replaced your wear ring...

  8. #8
    DustMan's Avatar
    Join Date
    May 2010
    Location
    NC
    Posts
    56
    +1
    1
    Any way to fix the cavatation?

  9. #9
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    Quote Originally Posted by DustMan View Post
    Yeah ET 127. Broke it in today. Set slip and went riding, Man what a ride. List of what I had to what I just put on
    Had riva thru hull, block off, r&d intake, 4" kana, short gutted water box,of course riva washers
    Put on last tuesday, 42's, 15/20R, ET 127, wear ring, boost gauge. Deaad stand still to full throttle it cavatates bad but if I just roll in to it then hammer down it halls the mail. Why is it?
    Power and a pump/driveline system that is meant for stock power numbers. Bellow Bands and a fresh carbon seal and bellows along with a good wear ring, proper alignment etc are things that can improve it but you will never get rid of it all without a high dollar pump setup.

  10. #10
    SLASHER's Avatar
    Join Date
    Jun 2007
    Location
    Australia, Perth WA
    Posts
    3,263
    +1
    474
    The Cavatation bug ... It's a pain in the ass ... It's like trying to work out women ...lol

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. video of speedster with 127 wheel in it. 60mph plus
    By gprxpduglas in forum Sea Doo Sport Boats
    Replies: 3
    Last Post: 02-15-2016, 11:01 PM
  2. Got past my break in and this is what I got!
    By Water4fire in forum 4-Tec Performance
    Replies: 12
    Last Post: 05-20-2005, 07:22 AM
  3. BREAK IN SUCKS!
    By BLOWNRXP in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 05-18-2005, 10:15 PM
  4. New Rxp break-in procedure
    By SUPERBEAST in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 05-09-2005, 05:53 AM
  5. Break in period and Noise at 5000rpms on 05 GTX Limited
    By spc9669 in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-08-2005, 11:30 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •