Results 1 to 7 of 7
  1. #1

    Taking on water big time. Help please!!!

    Like 8 to 10 inches of water in it after 20 mins of ride time.


    Cant really isolate it. Dont leak inside while running on hose on trailer. 2007 rxt. Been sitting 2. Years. 60 hrs. To run it on trailer hooked to hose the impeller sounds very loud and rattly compaired to the other identical ski i have next to it. Is there a bearing and seal in there. Almost seems to be way worse while running. Any ideas????????


    No hoses leaking or unhooked. And yes the plugs arein it.


    If i fill it inside on the trailer will the water run out of the impeller shaft if thats the problem??


  2. #2

    Join Date
    Sep 2012
    Location
    Westchester,NY
    Posts
    172
    +1
    6
    Ride it with the rear seat and vent tube off. Look at the carbon seal and bellows on the driveshaft. Also check the bailer tubes.

  3. #3

    Join Date
    Sep 2012
    Location
    Westchester,NY
    Posts
    172
    +1
    6
    The rattle noise is normal. I believe it is the driveshaft banging on the impeller. As long as you dont hear that rattle when its in the water. You may need a new rubber driveshaft end piece.

  4. #4
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Put water in the hull while its on the trailer and see where it leaks from.
    It's the best way to check it safely.
    If it doesn't leak then more than likely its the carbon ring and its leaking while in operation..
    Get r done....

  5. #5
    Madzooki's Avatar
    Join Date
    Jun 2012
    Location
    Corpus Christi, Texas
    Posts
    132
    +1
    2
    Quote Originally Posted by need4spd View Post
    If i fill it inside on the trailer will the water run out of the impeller shaft if thats the problem??
    Yes it should.
    Paul

  6. #6
    I second siphon tubes. See if they are both still in the jet pump stream

  7. #7
    Quote Originally Posted by Wire4Money View Post
    I second siphon tubes. See if they are both still in the jet pump stream
    Thanks guys. Will fill it at home and check it on the trailer first.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2004 RXP Taking on water... Please Help!
    By Redspider in forum 4-Tec Performance
    Replies: 40
    Last Post: 08-22-2015, 05:07 PM
  2. 95 Wave Venture 700 taking on water / help please
    By rockportwetriders in forum Yamaha Open Discussion
    Replies: 0
    Last Post: 06-08-2013, 09:39 AM
  3. Taking on water part 2. help please
    By need4spd in forum 4-Tec Performance
    Replies: 10
    Last Post: 06-04-2013, 08:14 AM
  4. XP hull taking on water!! HELP!!
    By WBoulton in forum 2-Stroke Performance
    Replies: 12
    Last Post: 05-01-2010, 08:43 PM
  5. RXP taking on water, need help...
    By JetmechF16 in forum Sea Doo Open Discussion
    Replies: 32
    Last Post: 10-21-2009, 03:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •