Results 1 to 3 of 3
  1. #1

    1997 SL 900 center cylinder rod failure

    What would cause the connecting rod to fail at the crank?


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    How old is the motor, since last rebuild, in years?

    How many running hours on that crank shaft?

    Was it left sitting for a long time! Was it exposed to moisture?

    Welcome

  3. #3
    Quote Originally Posted by K447 View Post
    How old is the motor, since last rebuild, in years?

    How many running hours on that crank shaft?

    Was it left sitting for a long time! Was it exposed to moisture?

    Welcome
    Thanks.Not sure on the last rebuild. I bought the ski in late summer of '10. It ran great with the exception of an idling issue and hard starts after running. I took it to a shop to have the carbs looked at the following spring. I forgot to put the battery in before I took it to the shop so they used their own to troubleshoot. They fried the CDI. Apparently the mechanic was not as familiar with PWCs as I thought. He called me saying the ski had no spark and suggested having the ski taken to a shop that knows more about them then they did. They strictly work on boats, not many PWCs. Long story short, the other place put in the upgraded CDI and stator. Ran great but still had the same hard start after running. Maybe 15 hours after the new CDI it threw the rod. Cylinder looks good, cylinder gasket was in pieces and an exhaust manifold bolt was loose. I am installing a new short block and will rebuild the one I just took out.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 97 SL 900 center cylinder rod failure
    By jman134 in forum Open Discussion
    Replies: 0
    Last Post: 06-01-2013, 10:21 AM
  2. 1997 SL 900 issues
    By ThetaDgt in forum Polaris Open Discussion
    Replies: 6
    Last Post: 06-28-2010, 01:03 AM
  3. WTB: Purple floor mat for 1997 SL 900
    By rjcapo02 in forum Polaris Classifieds
    Replies: 0
    Last Post: 08-17-2009, 10:48 AM
  4. 1997 SL 900 with 29 hours on it, part out?
    By Piranha Performance in forum Polaris Open Discussion
    Replies: 0
    Last Post: 07-08-2009, 12:25 PM
  5. Quick question (hopefully) on a 1997 SL 900
    By JJCleveland in forum Polaris How To & FAQs
    Replies: 3
    Last Post: 05-19-2009, 05:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •