Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11

Thread: NEED HELP!!!

  1. #1

    NEED HELP!!!

    I have a 2013 Seadoo Rxp-x 260, with 16 hours. Riding today, what seemed to be the engine, started making a knocking/grinding sound at any speed above 6 mph. Immediately turned it off and towed it back to the landing. However, no lights/codes popped up. Checked the intake grate and couldn't find anything stuck up in there. Please shed some light on what this might be, if you can. Thank you.


  2. #2
    leejax01's Avatar
    Join Date
    Apr 2011
    Location
    Jacksonville
    Posts
    1,161
    +1
    98
    Check to see if you possibly have something wrapped around the driveshaft. Look good as you can miss something. Then check the oil level. Should be under warranty, so at least have that to fall back on.

  3. #3
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472

    Cool

    Grinding sound could be the drive shaft splines stripped.
    Knocking??

    You could have sucked something into the pump and your impeller was chewing it up.
    Get under the ski and look into the intake grate and shine a light if necessary to check the impeller for dings...
    If you have dings there is something in there and you should pull the pump and inspect it and replace the wear ring.

    Warranty doesn't cover something getting sucked up.

    Once you do find the issue please update this thread.

    Good luck!!

  4. #4
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    With no codes showing up I doubt its motor related.
    Sensors all over the motor to show problems but none in the pump area..

  5. #5
    Guys thank you so much for the replies... Unfortunately, a half mile from my house, while stopped I was rear ended by a moving truck. The seadoo is destroyed, so I was never able to check for anything... So I guess I'll be waiting until I get a new one sometime soon. Again, thank you so much for all of your replies.

  6. #6
    leejax01's Avatar
    Join Date
    Apr 2011
    Location
    Jacksonville
    Posts
    1,161
    +1
    98
    You can't be serious. Got pics??? Insurance should cover... no?

  7. #7
    Yupp, and insurance will be covering it. Thank god. Also have to get the frame of my Jeep tested to make sure it didn't bend or twist any. Had to pull the hitch from the receiver with a little banging on it, because the ball wouldn't come out of the trailer.

  8. #8
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Atleast your ok.

    Everything else can be replaced.

  9. #9
    Tiny's Avatar
    Join Date
    Sep 2006
    Location
    The Atl
    Posts
    3,561
    +1
    578
    Holy shit!!!

  10. #10
    Q in Arizona's Avatar
    Join Date
    May 2013
    Location
    Phoenix, Az
    Posts
    30,504
    +1
    7,337
    Unreal. At least everyone is ok.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. new 05 RXT NEED HELP
    By RXPNJ in forum 4-Tec Performance
    Replies: 12
    Last Post: 07-03-2009, 12:16 PM
  2. NEED HELP URGENT(HULK) RXP DOWN
    By macattack in forum 4-Tec Performance
    Replies: 28
    Last Post: 11-22-2005, 02:39 PM
  3. My 2 RXP's need HELP!
    By Tube Master in forum 4-Tec Performance
    Replies: 21
    Last Post: 07-19-2005, 09:44 PM
  4. I need help remove stock intercooler
    By orc in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-13-2005, 04:08 PM
  5. NEED HELP!!!!!
    By MartyRXP in forum 4-Tec Performance
    Replies: 11
    Last Post: 05-10-2005, 08:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •