Results 1 to 5 of 5
  1. #1

    Join Date
    Nov 2008
    Location
    Stuart ,Fl
    Posts
    99

    97 WR 3 won't rev up.....trouble shooting

    Hi,
    great forum with real answers.....but you knew that

    Have a new jet ski project.
    The ski won't go over about 2000 rpm.
    1997 with 700cc motor.
    New plugs
    great spark
    compression is 150 and 140
    oil injected
    So far i've replaced carb with know good one.
    inspected reed valves which look good.
    shot some starting fluid in carb and no difference in rpm.

    Is there a rev limiter on this motor?
    could the cdi be defective?
    Perhaps overheat protection....
    I'm stumped on this one.
    thanks for any help.


  2. #2

    Join Date
    Nov 2008
    Location
    Stuart ,Fl
    Posts
    99
    So i'm going after the overheat sensor to see if it's stuck.......be nice if it's that easy.

  3. #3
    Yamaha artisan Cutlass's Avatar
    Join Date
    Oct 2010
    Location
    Madison, WI, USA
    Posts
    2,500
    +1
    55
    Kinda sounds like an overheat/limp mode or a failed CDI. I think you have the right idea.

  4. #4

    Join Date
    Nov 2008
    Location
    Stuart ,Fl
    Posts
    99
    Just got back and the overheat temp sensor was bad. AND neow for the next step.
    Removing it.... It's jambed up in there. The wires are pulled out of it but the metal stayed. I have pb blaster on it overnight but it looks to be really stuck.
    Any tricks to removing the metal portion outta the head.
    thanks

  5. #5
    Yamaha artisan Cutlass's Avatar
    Join Date
    Oct 2010
    Location
    Madison, WI, USA
    Posts
    2,500
    +1
    55
    There are 3 ways to remove corroded stuff. Soak it with penetrating lube (repeatly if necessary), vibrations, and heat. Or any combo of 2 or 3 of those.
    Propane torch might do it but might not. Oxy acetylene torch would work better. Or maybe an air impact wrench

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 97 polaris SLT won't rev up
    By cumminsbayou in forum Polaris Open Discussion
    Replies: 5
    Last Post: 07-21-2013, 11:43 AM
  2. 1999 1100 STX flooded out won't rev up
    By carms_us in forum Kawasaki Open Discussion
    Replies: 2
    Last Post: 10-20-2010, 10:56 PM
  3. 97 XP won't rev up HELP!!!
    By jared427 in forum 2-Stroke Performance
    Replies: 2
    Last Post: 09-01-2008, 07:19 PM
  4. 97 XP won't rev up HELP!!!
    By jared427 in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 08-25-2008, 12:39 AM
  5. MSX 110 Won't rev up fully
    By bcbill in forum Polaris Open Discussion
    Replies: 4
    Last Post: 05-26-2007, 12:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •