Results 1 to 3 of 3
  1. #1

    1994 SL 650 running problems

    So we got a pwc a few weeks back, its a 1995 SL 650. The problem is that it runs for a few minutes then just cuts out. Any suggestions?

  2. #2
    Carson's Avatar
    Join Date
    Jul 2011
    Can we have more details? Does it die out while idling? Does it boggle down when pressing the gas? What are the RPM's when the ski cuts out? Have you check compression on the cylinders? Have you upgraded to the triple fuel pump? Then I can help you out more bud. Thanks. Sorry to sound like a prick! Just here to help

  3. #3
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Medina, Ohio, United States
    In addition to Carson's comments..... What do you set the fuel select switch to when you run it? Do you have any pressure build up in the gas you hear a sound like air is trying to get in or out quickly when you remove the gas cap?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 6
    Last Post: 05-01-2012, 05:59 PM
  2. FS 1994 SL 650 non-running but with rebuilt motor and extra hull
    By elad in forum Polaris Classifieds
    Replies: 0
    Last Post: 08-04-2011, 03:35 PM
  3. 1987 SX 650 running problem
    By fast280 in forum Kawasaki Projects
    Replies: 1
    Last Post: 07-20-2011, 09:47 PM
  4. Polaris sl 650 running problem
    By allyfonzo in forum Polaris Open Discussion
    Replies: 2
    Last Post: 09-10-2010, 07:52 PM
  5. sl 650 running problem
    By polaris650 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 06-26-2008, 10:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts