Results 1 to 6 of 6

Thread: Electrical ?

  1. #1
    WVGP1200R's Avatar
    Join Date
    Apr 2006
    Location
    Winfield, WV
    Posts
    231
    +1
    14

    Electrical ?

    I hooked up my Innovate Mtx-l to the wire in the front of the ski (red with yellow stripe) to power the gauge and it all works well.

    Question is if I add a mtx digital boost gauge can I use the same source to power the boost gauge or will that be to much of a power drain on that source?
    In other words do I need to find another wire to power the boost gauge?

    Sorry but electrical is not my thing and I have very little knowledge with it.

    Thanks.
    Last edited by WVGP1200R; 06-03-2013 at 10:11 AM.


  2. #2
    AWA MEMBER
    Join Date
    Jan 2008
    Location
    Currituck, North Carolina, United States
    Posts
    4,616
    +1
    247
    it should be fine, only the MTX-L is the power consumer.....the boost gauge should be fine

  3. #3
    WVGP1200R's Avatar
    Join Date
    Apr 2006
    Location
    Winfield, WV
    Posts
    231
    +1
    14
    Quote Originally Posted by RickWhite View Post
    it should be fine, only the MTX-L is the power consumer.....the boost gauge should be fine
    So the digital boost gauge doesn't use much power? I just wanted to make sure. I may just use an analog gauge but thought at least the digital mtx boost gauge will match my AFr gauge.

    Thanks.

  4. #4
    AWA MEMBER
    Join Date
    Jan 2008
    Location
    Currituck, North Carolina, United States
    Posts
    4,616
    +1
    247
    yes the boost gauge uses hardly any juice....... Put a inline fuse on it for extra protection..... 3amp should be plenty:

  5. #5
    WVGP1200R's Avatar
    Join Date
    Apr 2006
    Location
    Winfield, WV
    Posts
    231
    +1
    14
    Ok. Thanks!

  6. #6
    Kristian Keppel Waterholics's Avatar
    Join Date
    Apr 2010
    Location
    Trinidad & Tobago
    Posts
    1,405
    +1
    38
    You really need alot of power to power the MTX-L or else will get an E8 code. If I were you I would hook it up to a relay just to be sure.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. chasing electrical gobblins-- plug 1 all messed up
    By rapidacceleration in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 05-29-2006, 08:42 PM
  2. Update on my electrical troubles!!!!
    By ccassone in forum 2-Stroke Performance
    Replies: 22
    Last Post: 04-19-2006, 01:45 PM
  3. removing pins from electrical plugs?
    By Lurker in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 02-10-2006, 01:54 PM
  4. Electrical supercharger ?
    By Sammy-swed in forum 4-Tec Performance
    Replies: 4
    Last Post: 12-05-2005, 04:36 PM
  5. Electrical Problems
    By Red Devil in forum 4-Tec Performance
    Replies: 2
    Last Post: 10-31-2005, 07:42 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •