Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 25
  1. #1

    Join Date
    Mar 2012
    Location
    Canada
    Posts
    7

    Guys, what is this?

    Was cleaning out the engine a bit.. and noticed this.

    How concerned should I be?

    Since people and too many pictures get confused here is one picture so people don't get confused so easily.



    2008 RXP-X
    Last edited by Polestar; 06-04-2013 at 09:28 AM. Reason: derp people


  2. #2
    Tiny's Avatar
    Join Date
    Sep 2006
    Location
    The Atl
    Posts
    3,561
    +1
    578
    3 different pics of 3 different things??? What thing are you concerned with???

  3. +1 by:


  4. #3
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Wow.
    So we are looking at an overview of your entire motor...

    So are we suppose to guess what's wrong???

    Tick tock tick tock....
    I think your suppose to puff puff pass..

  5. #4
    r33pwrd's Avatar
    Join Date
    Mar 2006
    Location
    Sammamish Washington
    Posts
    4,216
    +1
    360
    Is that oil / water in there?

  6. #5
    Boost-A-Holic's Avatar
    Join Date
    Jul 2012
    Location
    Dallas, Texas, United States
    Posts
    1,173
    +1
    94
    looks like a lil bit of corrosion/salt related build up. try to clean it up a bit and see what happens.

  7. #6

    Join Date
    Mar 2012
    Location
    Canada
    Posts
    7
    Quote Originally Posted by Tiny View Post
    3 different pics of 3 different things??? What thing are you concerned with???
    Really? Seriously?
    Last edited by Polestar; 06-04-2013 at 09:28 AM. Reason: derp Tiny

  8. #7
    Bob 1tommygunner1927's Avatar
    Join Date
    Apr 2007
    Location
    Houston, Texas
    Posts
    6,362
    +1
    975
    Hmmm.....cam chain tensioner retaining bolt missing?

  9. #8

    Join Date
    Jun 2012
    Location
    Morgan City, LA
    Posts
    304
    +1
    4
    Are you taking those pictures with a potato?

  10. #9
    83.0 @ 8400 jhill19's Avatar
    Join Date
    Jul 2010
    Location
    Teays Valley, West Virginia
    Posts
    2,800
    +1
    81
    Quote Originally Posted by 1tommygunner1927 View Post
    Hmmm.....cam chain tensioner retaining bolt missing?
    no it's in there it's just rusted up...

  11. #10
    Mothman's Avatar
    Join Date
    May 2011
    Location
    West Texas
    Posts
    2,996
    +1
    1,477
    Quote Originally Posted by Polestar View Post
    Quote Originally Posted by Tiny View Post
    3 different pics of 3 different things??? What thing are you concerned with???
    Really? Seriously?
    There were three pictures yesterday. I didn't respond for the same reason.
    The muddy/rusty build up may be a sign of the hull filling with water and sitting on a trailer for awhile. Definitely some serious corrosion on that oil cover, the paint is bubbling up.
    Point at the specific problem to help us out!

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. What is this guy smoking? $500 !!! Thought I would share from Tulsa craigslist.
    By elk river rascal in forum Polaris PWC Performance
    Replies: 4
    Last Post: 07-18-2015, 10:31 AM
  2. what you guys think is this ok or is something wrong
    By hirola187 in forum 4-Tec Performance
    Replies: 5
    Last Post: 10-18-2014, 08:09 AM
  3. What is this???
    By FireFox in forum 4-Tec Performance
    Replies: 10
    Last Post: 06-20-2006, 03:49 PM
  4. What is this for
    By brad2510 in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 05-08-2006, 08:55 AM
  5. what is this new rr supercharger?
    By Lurker in forum 4-Tec Performance
    Replies: 1
    Last Post: 04-03-2006, 08:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •