Results 1 to 8 of 8
  1. #1
    canadian iceman
    Join Date
    Dec 2007
    Location
    medicine hat, alberta, canada
    Posts
    627
    +1
    22

    12-13 rxpx owners please chime in!

    has anybody tried to put a later model pump 2008 into a newer rxpx?...the cone on the back of the pump has a offset bolt pattern and I want to run an aftermarket adjustable cone...anybody?


  2. #2
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    I haven't..
    How's that going to affect your performance??

  3. #3
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    The pump will work. Just make sure you use a older style prop.

  4. #4
    Tiny's Avatar
    Join Date
    Sep 2006
    Location
    The Atl
    Posts
    3,561
    +1
    578
    Are the bolt holes the same size??? I know they changed the size of the nuts on the newer skis, are the studs they same size.....

  5. #5
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Quote Originally Posted by Tiny View Post
    Are the bolt holes the same size??? I know they changed the size of the nuts on the newer skis, are the studs they same size.....
    Yep. Bolt holes are good, studs are smaller on the new ski. When I was in Fla last Nov for the HD's I ate a wear ring riding the St Johns. Duke had a 08 pump with a good wear ring, so we put my 12 prop in the 08 pump and bolted it up. Everything went together just fine, but the prop locked up after I started it.

  6. #6
    Bob 1tommygunner1927's Avatar
    Join Date
    Apr 2007
    Location
    Houston, Texas
    Posts
    6,378
    +1
    981
    Quote Originally Posted by troyheb View Post
    The pump will work. Just make sure you use a older style prop.
    I'm using a Solas SRZ in my 08 pump. It needs trimming, about .050" or setback, to work in the older pumps.

  7. #7
    canadian iceman
    Join Date
    Dec 2007
    Location
    medicine hat, alberta, canada
    Posts
    627
    +1
    22
    hmmm locked up eh?...so what was the result? ....thrust washers in engine gone?...let me no as I am about to tear apart my new 2012 and make it fast...new everything and I want to use my older 08 pump......

  8. #8
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Quote Originally Posted by IM2FAST4U View Post
    hmmm locked up eh?...so what was the result? ....thrust washers in engine gone?...let me no as I am about to tear apart my new 2012 and make it fast...new everything and I want to use my older 08 pump......
    No. Just the prop locked up in the pump. The motor was/is fine. That was 60+ hrs ago. Bob is right also. You can use a newer SRZ, but you have to mill that lip off of it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Mystery regarding Viper Red (Please chime in!)
    By Ski Hacks MG in forum Sea Doo Open Discussion
    Replies: 44
    Last Post: 05-15-2017, 04:19 PM
  2. Impeller pro's please chime in!!!
    By IM2FAST4U in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-23-2015, 04:06 PM
  3. painting questions please chime in if you have custom paint
    By RXPSTUNNA in forum Conversion FAQ and Tips
    Replies: 2
    Last Post: 10-07-2010, 10:59 AM
  4. Rebuilding my Carbs. AGAIN! Please chime in ... POP OFF and Springs Yama1200xlt 2005!
    By vjkevlar in forum Yamaha PWC Performance (2-stroke)
    Replies: 116
    Last Post: 07-29-2008, 12:20 PM
  5. Kerr Lake Ride in N.C Aug 11,12,13
    By Hypertoys in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 07-28-2006, 01:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •