Results 1 to 10 of 10
  1. #1

    1997 Kawasaki zxi 750 help

    So I just bought my first jet ski for what I hope was a great deal. I bought it not running and it has sat for a few years. The guy I bought It from went into the military and was stationed elsewhere so the ski has sat in his fathers barn and his dad wanted it gone. The problem is that it doesn't start, I put a battery in and go to turn it over but nothing. Starters bad maybe? Or are there know electrical bugs with this ski, anything I should know about replacing or checking to prevent future issues. I was going to rebuild carbs, replace plugs, replace some lines if needed, that is if I could get it to to turn over. Also was reading up about some plug on bottom of the engine which can deteriorate and cause a lean condition.
    thanks for the help


  2. #2
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,529
    +1
    1,279
    welcome to the hulk.

    first order of business...

    remove black plastic driveshaft cover in the rear of the engine bay ( couple of 10mm bolts)

    get a big pair of channellocks

    grab the driveshaft

    try to turn the shaft

    don't start taking anything else off..assume it was running when put away.

    2nd business

    pull spark plugs, check for rust or bits of metal or impact damage

    spray some wd-40 down the plug holes.

    report back on results

  3. #3
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,014
    +1
    285
    Welcome aboard, Dustin!

    Did you turn on the orange switch?

  4. #4
    Dialga's Avatar
    Join Date
    May 2013
    Location
    California
    Posts
    99
    +1
    8
    Lol, what kind of question is that?

  5. #5
    Lol, yes the ski is on, turns over by hand checked that before I bought it. Power to all gauges and power on volt meter to starter but won't turn over like starters bad or maybe a relay?

  6. #6
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,014
    +1
    285
    Remove the Starter cable from the ignition box and touch it directly to the + battery terminal. It will spark, so make sure you don't have any gas fumes around. The starter should engage and crank the engine if it's good. If not, time to pull the starter.

  7. #7
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,014
    +1
    285
    Quote Originally Posted by Dialga View Post
    Lol, what kind of question is that?
    With a new member with a new 'Ski, we have to assume they know nothing. Hell, we even get people here that don't know what kind of oil to use!

  8. #8
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,529
    +1
    1,279
    +1..we spewed about two dozen messages to help a new member last month and it turned out he had not turned on the fuel, so expect insultingly stupid questions.

    well the motor isn't seized from sitting unattended for two years..that in itself is a +1

    on the 750zxi you can jump the solenoid from outside the battery box without disconnections. Standard accidental explosion precautions suggested when you use a big screwdriver to jump the connections

    if you are getting 12v on the starter side, the starter should be suspect.

    no heavy clicking when you hit the starter button?

  9. #9
    No clicking at all will try jumping the starter tomorrow

  10. #10
    Bought it three days ago fixed it today, rode it today, sold it. Was getting power to starter but not full twelve volts, fixed it but replacing wire and starter acted like it was seized, taped with hammer and it was fine. In search for some new machine in the NY, PA area

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1997 kawasaki zxi 900 electrical problems
    By Jetskikid in forum Kawasaki How To & FAQs
    Replies: 1
    Last Post: 06-07-2011, 05:24 PM
  2. kawasaki zxi 750
    By deer40111 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 4
    Last Post: 03-24-2011, 10:27 PM
  3. kawasaki zxi 750 exhaust manifold studs coming loose
    By deer40111 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 0
    Last Post: 08-06-2010, 01:16 PM
  4. kawasaki zxi 750 exhaust manifold studs sheering
    By deer40111 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 0
    Last Post: 08-05-2010, 10:57 PM
  5. Kawasaki zxi 750 HELP! PTO!
    By TX21 in forum Kawasaki Open Discussion
    Replies: 1
    Last Post: 07-04-2008, 02:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •