Results 1 to 6 of 6
  1. #1
    Choad's Avatar
    Join Date
    Mar 2013
    Location
    Wollongong Australia
    Posts
    12

    RXDI technical help needed

    Hi all i,m in need of some technical help i have just purchased a 01 rxdi with 123hrs on it.when i got it it was running rough at idle i discovered air leaking from the hose that gose into rave valves fixed the hose and now idles fine but when i took it for a lake test it would not get up to top rpm it takes off fine but when you give it full throttle it is like a flat spot you can hear the change in the motor it gose from a strong rev to a flat sound it also has a low 12v message is coming up on the display i have been reading other threads too find out more and have read about the fuel pump, 12v regulator and injectors. I don't think the fuel pump is to blame it looks like shit has rust on top but is operating as it should every where else after that is the injectors which could be the suspect so they will be coming out for inspection. what do i look for and how do i test and clean them, it will be the same for the regulator where is it located and what voltages should i be getting. I've metered the battery and i'm getting 12.3v charge seams low but is above 12v


  2. #2
    dan87951's Avatar
    Join Date
    Apr 2010
    Location
    Lansing, MI
    Posts
    65
    What is the voltage reading on the battery with the jetski running?

  3. #3
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,530
    +1
    1,281
    12.3 is way too low for the voltage @ battery with a running engine

    12v low warning will put the engine into limp(reduced power) mode..as a stern warning to get back to shore before you end up getting stranded.

    regualtors are known issues on the big two stroke seadoos with injection

    most likely you need a voltage regulator..but make sure the battery is in top notch shape and all connections are secure.

    Proper diagnostics of a DI ski requires a code reader of some sort. candoo being the popular model.

    but for the moment, a new regulator seems to be needed.

    It's not a bad idea to have a spare in your toolbox anyhow, since they fail on what seems to be a regular basis.

    I wouldn't pull the injectors at this time. When the battery is showing 13v+ at idle speed and 14+ at midrange you can see how she performs.

    Until then keep reading..there is plenty of useful information on Di's on the forum

  4. #4

    Join Date
    Jan 2007
    Location
    PCB, FL
    Posts
    69
    +1
    1
    It is likely the rectifier. I have had these fail on several DI skis and gotten the 12V LOW message. If it is not the rectifier, next test would be the magneto. The rectifier is located behind the MPEM bracket, front left hull. If the rectifier ends up being the culprit, be sure the battery is fully charged before cranking/running after replacement and any subsequent outings to prolong the rectifier's life.

  5. #5
    Choad's Avatar
    Join Date
    Mar 2013
    Location
    Wollongong Australia
    Posts
    12
    After finishing my Job's for the wife final'y got a chance today to have another poke around inside the ski. The magneto seams fine with 13.4v at idle so it looks like were all going to blame the rectifier i will purchase a new one and give this one the flick, get the ski out of limp mode and see the result. I have been looking at buying a CANDOO system and was wondering if the home edition which gives you 4 spots, weather you can delete the spots if you fill them? Thanks to Dan Peter and Big Kid for your help ill buy the beers next time i see you

  6. #6
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,530
    +1
    1,281
    measure the a/c voltage at the battery to see if the regulator is spitting noise into the system.

    you can license additional skis on the home version of candoo, you cannot delete slots that have been allocated to a particular ski's hin# ( read from the mpem/ecu) see the site for the pricing.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Home Audio Help Needed
    By Franko in forum Sea Doo Open Discussion
    Replies: 13
    Last Post: 08-24-2007, 10:45 AM
  2. Help needed on ZXI 1100
    By Turbo Todd in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 07-18-2005, 11:49 AM
  3. Help needed
    By rxpblast in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-07-2005, 09:20 AM
  4. Help needed badly!
    By RXPinMD in forum 4-Tec Performance
    Replies: 37
    Last Post: 07-06-2005, 10:03 PM
  5. Help - need RXP battery dimensions
    By Vern in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 06-28-2005, 05:42 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •