Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1

    SC...How did this happen???

    I have no clue how this happened, I thoroughly checked the intake and didn't find any signs of anything being sucked in...If something was sucked in and caused this damage I would expect the whole inside the be damaged not just the tips.

    Ideas? I don't want to replace it until I know what happened.

    Click image for larger version. 

Name:	IMG_3471[1].jpg 
Views:	372 
Size:	89.6 KB 
ID:	302949


  2. #2
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    You ingested something from how this looks. What kind of air intake you running?

  3. #3
    Stock intake

  4. #4
    Eric Ocman's Avatar
    Join Date
    Aug 2008
    Location
    Cataula, Georgia, United States
    Posts
    4,700
    +1
    77
    Did you find any debris anywhere? You may want to take a look at the throttle body and ic as well.

  5. #5
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Quote Originally Posted by glitchen View Post
    I have no clue how this happened, I thoroughly checked the intake and didn't find any signs of anything being sucked in...If something was sucked in and caused this damage I would expect the whole inside the be damaged not just the tips.

    Ideas? I don't want to replace it until I know what happened.

    Click image for larger version. 

Name:	IMG_3471[1].jpg 
Views:	372 
Size:	89.6 KB 
ID:	302949
    Did you spray all the water in it???

  6. #6
    No debris anywhere, I just put the SC back on last week and it was running ok until I sucked a rock into the jet pump. Since I took the pump off to replace the wear ring I was going to replace the carbon ring and came across it once I took off the sc.

    It was raining when I took the pic is why it's wet.

  7. #7
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    You got some issues going on. It looks like you wiped a bunch of oily residue out of the SC intake.

  8. #8
    If i knew,...I wouldn't ask sea-one's Avatar
    Join Date
    Aug 2009
    Location
    Dallas/Waxahachie
    Posts
    2,340
    +1
    109
    Man I'm Stumped Too?

  9. #9
    GGG's Avatar
    Join Date
    Sep 2009
    Location
    Jersey Shore
    Posts
    2,830
    +1
    258
    If whatever did that made it through, it's def in the intercooler. take the intake hose off and look through the throttle body with a light and possibly a mirror.

  10. +1 by:


  11. #10
    CHAD IBADTON's Avatar
    Join Date
    Jul 2008
    Location
    on lake Harding AL
    Posts
    558
    +1
    34
    Did you buy ski new? What ski?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How did this happen
    By Doorgunner in forum Yamaha PWC Performance (2-stroke)
    Replies: 12
    Last Post: 07-29-2014, 06:40 PM
  2. How did this happen to my stator?
    By soulraver in forum Yamaha Old School Skis
    Replies: 2
    Last Post: 09-30-2010, 05:06 PM
  3. How does this happen to Me twice
    By miamirider in forum 4-Tec Performance
    Replies: 57
    Last Post: 06-02-2008, 02:43 PM
  4. how did this happend?
    By pet in forum 4-Tec Performance
    Replies: 24
    Last Post: 09-21-2007, 01:09 PM
  5. How does this happen UP-DATED.........
    By peteshauling in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 10-04-2006, 06:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •