Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1
    ajharbin's Avatar
    Join Date
    Feb 2013
    Location
    Douglasville,GA
    Posts
    32
    +1
    1

    First run on the new ski!!!

    So I recently Purchased a 01 Gp1200r with a blown top end. I rebuilt the top end with SBT parts went through the bottom end and such. Took the ski out today for the first ride and it will run about 63 MPH on the speedo I'm running about 150psi compression my mods are a factory Cylinder head which was milled before I got the ski, riva s2 exhaust, FF exhaust, solas 13/19 impeller, pump plug kit, and a R&D intake grate, also wave eater clips. My question is, is this slow for the mods I have or what. The ski is crazy quick on hole shot but just seems a little slow on top end. As soon as I get my gps back I will see what I get on it but for now I was just going to see what the Experts had to say. Any input will be greatly appreciated. Thanks in advanced
    AJH


  2. #2
    What kind of RPM's is it turning? Also may want to adjust your Power Valves per the manual...it's pretty easy.

  3. #3
    ajharbin's Avatar
    Join Date
    Feb 2013
    Location
    Douglasville,GA
    Posts
    32
    +1
    1
    on the speedo it says it turns 7k. I dont have a manual but I do see a bunch of threads on how to set them I ordered a new set of cables I noticed that the old ones are frayed so once I get those in I will adjust them and see how it runs. One question i did have was if I put my factory pipe with d-plate back on the ski will it faster on top end then the s2.

  4. #4
    Superman! fivespeedsteed's Avatar
    Join Date
    May 2010
    Location
    Midlothian VA
    Posts
    1,058
    +1
    14
    Do it with a GPS. And get a tach

  5. #5
    Hey Ajharbin,

    Your ski looks exactly like mine. You heading to Allatoona this weekend? I'll be there Saturday if the weather looks good and the wife agrees. About 11am at Victoria Marina's beachfront.

    PM me if you want to meet up!
    Eric

  6. #6
    Ski Hacks MG's Avatar
    Join Date
    Apr 2013
    Location
    Georgia
    Posts
    5,253
    +1
    990
    Allatoona sounds fun.

  7. #7
    Sure does. i picked up a knee board the other week. 3-up anyone?

  8. #8
    Chupacobra's Avatar
    Join Date
    Jun 2012
    Location
    Orlando, FL
    Posts
    1,372
    +1
    409
    Make sure the Power Valves are functioning.

    Remove the seat and start the ski once its on shut it off and see if the valves cycle when it shuts off.

  9. #9
    ajharbin's Avatar
    Join Date
    Feb 2013
    Location
    Douglasville,GA
    Posts
    32
    +1
    1
    What is a good Tach to buy? and Zeroclient I would love to go to Allatoona but I will busy this weekend maybe sometime soon we can meet up and ride!

  10. #10
    camaro630hp's Avatar
    Join Date
    May 2012
    Location
    marietta ga
    Posts
    191
    +1
    15
    Altoona is my spot aswell. . We all need to meet up and ride sometime. I will be out of town all week and next weekend. But I'm down anytime. Hit me up.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. First run on the lake.. HELP!!
    By theslth98 in forum Polaris PWC Performance
    Replies: 7
    Last Post: 05-29-2016, 07:00 AM
  2. Finally got past the 5 hours on the new skis
    By Mpeavler in forum 4-Tec Performance
    Replies: 9
    Last Post: 05-31-2015, 10:18 AM
  3. Replies: 67
    Last Post: 09-15-2014, 04:46 PM
  4. Changed some things around on the new ski....
    By smbstyle in forum Yamaha Open Discussion
    Replies: 29
    Last Post: 12-01-2009, 08:43 AM
  5. first ride on my new skis
    By luckyc1423 in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 11-07-2009, 08:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •