Results 1 to 6 of 6
  1. #1

    Join Date
    May 2011
    Location
    Oklahoma
    Posts
    20

    Ski is dieing with new battery

    I just replaced my battery in my 2001 1100 STX DI ski and took it to the lake. I made sure it was fully charged and let it sit on the charger for more than 24 hours. I took it out to the lake and it was working fine at first then it would just die while I was accelerating. I would try to start it again and it would not have enough power to turn it over so I had to turn the key off for a minute then it would turn over fine but it kept doing this till I limped my way back. I thought that it might just be some corrosion on the metal so I did my best to scrap them with a screw driver and put it back together and I was still having the same problem. I am going to take a wire brush to them and see if that helps but does anyone know what else it could be? What is the best way to clean your battery cables and make sure the connection is good?


  2. #2
    John2037's Avatar
    Join Date
    May 2013
    Location
    Clearwater, FL
    Posts
    10
    Is it charging? Sounds like you've got charging problems....

  3. #3
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,011
    +1
    283
    Have you cleaned the connections on the starter, the ground, and on the starter relay? Relay might be bad, starter might be getting tired.

  4. #4

    Join Date
    May 2011
    Location
    Oklahoma
    Posts
    20
    I have cleaned them now but I haven't taken it back out to the lake yet to test. Why would you think it's the starter when it happens while I am driving it. It starts just fine when it gets the charge to start it.

  5. #5

    Join Date
    May 2011
    Location
    Oklahoma
    Posts
    20
    Okay I tested it ut last weekend and this is what happened. I took it off the battery tender and brought it to the lake and it started just fine. Then when I was riding it between 15 and 20 mph it would bog or stutter or how ever you want to put it but I had hammered down and it would just speed up then slow down and kept doing that for a little bit then it would catch and go over 20 mph and be fine until you let off the gas. I also didn't have much gas in it and it was a mix of last years gas and some from this year. I had also put seafoam in it before I ever ran it this year. I also had a problem when I went to load it up. I parked it when and got the trailer and waited in line 15 min. I went to go put the ski on the trailer and it wouldn't start because of the battery again. Please help me.

  6. #6
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,011
    +1
    283
    Quote Originally Posted by cbay4duke View Post
    I have cleaned them now but I haven't taken it back out to the lake yet to test. Why would you think it's the starter when it happens while I am driving it. It starts just fine when it gets the charge to start it.
    Guess I misread it, you mentioned that you were having trouble with it cranking.

    The DIs were known for having electronic control module problems. I'm not familiar with them, but there is a place that can repair them. Do a search here.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Low voltage warning with new battery ultra LX. Ideas?
    By caliburst in forum Kawasaki How To & FAQs
    Replies: 17
    Last Post: 07-13-2016, 07:43 AM
  2. Low voltage warning with new battery ultra LX. Ideas?
    By caliburst in forum Kawasaki PWC Performance (4-stroke)
    Replies: 17
    Last Post: 07-13-2016, 07:43 AM
  3. Replies: 4
    Last Post: 06-17-2014, 08:49 PM
  4. First Ride With New Skis ??? Questions
    By rickreeves1 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 05-27-2007, 11:03 AM
  5. SeeDoo Reacts with new Ski!
    By tomgtv in forum Kawasaki PWC Performance (4-stroke)
    Replies: 4
    Last Post: 10-01-2006, 12:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •