Results 1 to 5 of 5
  1. #1

    Join Date
    Jun 2013
    Location
    Newberry, Florida
    Posts
    96

    Jet pump impeller stuck, bearing removal

    I have a 96 sl780 I just picked up. The pump was locked up and I got it for free!
    I'm trying to get the impeller out and it won't budge.
    What am I doing wrong?


  2. #2
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Quote Originally Posted by Porkchop_ina_Can View Post
    I have a 96 sl780 I just picked up. The pump was locked up and I got it for free!
    I'm trying to get the impeller out and it won't budge.
    What am I doing wrong?
    Welcome to the Hulk! You should start your own thread with some detailed information so we can help. Have you removed the jet pump yet?

  3. #3

    Join Date
    Jun 2013
    Location
    Newberry, Florida
    Posts
    96
    Thanks,
    I didn't want to clutter up the board with another issue of the same model.

    I got the impeller out
    I just got the rear bearing out.

    I tried tapping on the front bearing and its not budging.
    Does it have a C clip on it behind the first seal?

  4. #4
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Quote Originally Posted by Porkchop_ina_Can View Post
    Thanks,
    I didn't want to clutter up the board with another issue of the same model.

    I got the impeller out
    I just got the rear bearing out.

    I tried tapping on the front bearing and its not budging.
    Does it have a C clip on it behind the first seal?
    It doesn't clutter things. Every ski is different, even if it is the same make and mode. That said:

    No clips. Just needs to be knocked out. Pry both seals out first. You will need to use a good amount of force to pound it out. Put a good sized "punch" on the inner race of the bearing, from the back of the stator, and drive it out. The bearings will be garbage when you are done so need to source some new ones....

  5. #5

    Join Date
    Jun 2013
    Location
    Newberry, Florida
    Posts
    96
    Thanks,

    I got the bearings out. Just applied a little heat and the front one came out too.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Bad jet pump/impeller bearings?
    By RyMusic in forum 2-Stroke Performance
    Replies: 3
    Last Post: 09-15-2014, 11:32 AM
  2. Replies: 3
    Last Post: 09-14-2012, 05:08 AM
  3. STX15 Jet pump impeller stuck on driveshaft
    By squared in forum Kawasaki How To & FAQs
    Replies: 1
    Last Post: 09-18-2011, 09:45 PM
  4. jet pump impeller Question pic included
    By rdizz81 in forum Polaris Open Discussion
    Replies: 17
    Last Post: 05-22-2010, 03:27 PM
  5. 97 GTX jet pump oil for bearings?
    By awague2 in forum 2-Stroke Performance
    Replies: 2
    Last Post: 06-30-2008, 11:35 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •