Results 1 to 8 of 8
  1. #1
    TheGunMan's Avatar
    Join Date
    Feb 2013
    Location
    Las Vegas
    Posts
    454
    +1
    41

    2007 wake SC not getting over 7600 rpm

    Hi all,

    I have 2007 wake edition, supercharged with 50 hours on it. I got this ski last witer. The SC was rebuild by the dealer about 15 hours ago /have paperwork for this/. In the lake it can not go past 7600 rpm. There was more than 1/2 inc slack ont the throttle cable and I told this was tha problem but not - still ~7600. There is no info if the impeller was changed, but previous owner cept all the papers related to the ski and passed them to me so if there was impeller change he was going to tell me and to provide paperwork.

    My question is what can be the reaseon not to get over 7600 rpm. The oil was a bit overfiled but I pumped out sume and now is at the middle between min and max on the stick when the ski is leveled. The maintenence was done by the dealer when I got them and plugs are new, oil is changed and before winterization there was about gallon of fuel left which was mixed with premium all the way to full tank and injector cleaner few tanks ago. Checked the plugs and look normal and new, just very litle like hint of white on the metal base.

    Is it possible thet the dealer did not set the slip correctly after SC rebuild?

    Any iideas what to check will help

    Thanks


  2. #2
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Is it a 155hp or a 215hp?

  3. #3
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    It's a 215hp he was talking about the s/c rebuild.
    Yes its possible the slip on the s/c is not correct.
    A lot of dealerships have very bad techs working in them.
    If your a good tech normally you have your own shop.

    Did you check the oil correctly?
    It's different than checking your car oil.
    Also could be a different size impeller.
    You should be spinning around 8100.
    That rpm will drop a little the warmer it gets in the water.

  4. #4
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Are yall sure it has a 215 ecu? A 185 ecu rev limit is 7600.

  5. #5
    TheGunMan's Avatar
    Join Date
    Feb 2013
    Location
    Las Vegas
    Posts
    454
    +1
    41
    Quote Originally Posted by troyheb View Post
    Are yall sure it has a 215 ecu? A 185 ecu rev limit is 7600.
    It does not sound like rev limiter. I sounds like the engine can't rev more but not because of the limiter engaged

    What are the simptoms ot bad slip and can I check the slip and adjust it myself. I have lots of "regular" tools and can use them

    Thanks

  6. #6
    TheGunMan's Avatar
    Join Date
    Feb 2013
    Location
    Las Vegas
    Posts
    454
    +1
    41
    How can I make sure thet the ECU is for 215?

  7. #7
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    If its a stock 07 wake 215hp it wouldn't have a 185ecu.

  8. #8
    TheGunMan's Avatar
    Join Date
    Feb 2013
    Location
    Las Vegas
    Posts
    454
    +1
    41
    It is stock

    What I should check in order to bring RPMs back to what they should be.

    I can smell gas in the engine bay if that may lead to the problem

    I have candoo pro just delivered so i with it I can see some data which can pinpoint the problem.....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 99 xl1200 power valves cycling, but not opening at WOT, won't get over 5500 rpm
    By megan in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 07-19-2016, 01:36 PM
  2. 951 wont get over 2000 rpms
    By Joe Stang in forum 2-Stroke Performance
    Replies: 19
    Last Post: 10-01-2008, 06:10 PM
  3. Genesis, still not going over 3000 RPM ???
    By hajenhajen in forum Polaris PWC Performance
    Replies: 8
    Last Post: 06-11-2008, 07:29 PM
  4. Cant get Over 1800 RPMs?
    By xanthras in forum Polaris Open Discussion
    Replies: 2
    Last Post: 09-04-2007, 11:34 PM
  5. 2003 GTX SC not getting up to Speed Or RPMs ! Help !
    By RXPBeast in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 06-11-2006, 09:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •