Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 30
  1. #1

    Join Date
    Mar 2007
    Location
    Nashville, TN
    Posts
    25

    Smile Old Friends Reunited (SLT 780)

    My buddy bought a Polaris SLT 780 back in 96 and loved it. He let me borrow it a few times and we all thought that it was a great machine. A few months after he purchased it the PWC was stolen. Almost a decade later he recieved a call from the police saying that they recovered the ski (at a meth lab in Arkansas) and wanted him to come pick it up. He explained that it belonged to the insurance company and thought that it was over. 6 months later the insurance company called asking him if he wanted to buy it back, he offered $200 and they accepted. The machine appears to have sat the whole decade, it does not appear to have been abused.

    He has given me the ski to get it whipped into shape and I don't know where to start. I am assuming that the drug dealers did not winterize it. If you (experts) were me (no experience with PWC) where would you start. I am going to change out the plugs, drain the tank, install a new battery.

    Do I need to have the carb rebuilt? Is there a carb? Does anyone know if this is a good repair manual? Is there a free PDF anywhere?
    http://www.themotorbookstore.com/polwatvehsho1.html

    I hooked a 12v power supply to the power cables and the bilge and display turned on. It turned over but then the display turned off. I am worried that I may have damaged it but I don't know how. There was no short but the display will not come on again. The motor still turns over and the bilge still runs (non stop).

    Thanks for any help in advance.
    Mike (mikoo)
    Last edited by Mikoo; 03-01-2007 at 11:39 AM.


  2. #2

    Join Date
    Mar 2007
    Location
    Nashville, TN
    Posts
    25

    idiot

    found the carb.. I was looking for something round. I thought that maybe it was fuel injected. The carb looks really clean inside. I put a new battery in today and the LCD display is still not working. I am still mystified by this.

  3. #3

    Join Date
    Mar 2007
    Location
    Nashville, TN
    Posts
    25

    lucas gas treatment?

    Tune up in a bottle / The completet gas treatment
    Upper Cylander Lube and Injector cleaner

    They sold me this stuff at the boat shop. Anyone think its a bad idea to add this to the fuel?

    Does anyone think that I should switch out the 2 cycle oil because it is so old?

    What type of oil does the polaris slt 780 use? (marine 2 cycle?) with or without silicone? We don't have the manual for this thing anymore.

  4. #4
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Mike, WELCOME to the Green Hulk Forums. Amazing story!!!

    I'd get a little pre-mix 40:1 and drop it into the cylinders or through the carb throats and see if she'll fir off. If she does, replace the oil and fuel, freshen up the carbs, replace the plugs and see if she'll run on a water hose for a few minutes. Then head to the ramp, leave it strapped down, remove the seat and lower that bad boy into the water enough for the water opick up to deliver water. Run it and see if you have any visual leaks.

    Any TCW-3 2 stroke oil will work for now.
    Oh the MFD, NEVER, EVER, EVER start them while jumping the battery or while the battery is low, it will take them out.
    Disconnect the MFD for a couple of hours. Check for power and ground to the MFD, if there is no power supply, split the electrical box and check the fuse. Be sure to replace it with a like fuse.
    You say the bilge pump never stops running? I'll double check but I think you're going to find that's a voltage regulator.

  5. #5

    Join Date
    Mar 2007
    Location
    Nashville, TN
    Posts
    25

    wow, you guys are great!

    Thanks for tyhe quick response, I will try your suggestions and get back.

  6. #6
    Water Bum Rodneyae's Avatar
    Join Date
    Dec 2006
    Location
    Roanoke, Va
    Posts
    3,083
    Welcome!!!!

  7. #7
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407

  8. #8

    Join Date
    Mar 2007
    Location
    Nashville, TN
    Posts
    25

    Update!

    New plugs Installed
    Gas drained and replaced with lucas carb cleaned added
    New battery (West Marine power sports battery)
    I opened the carb and cleaned out what I could

    I dropped in in the marina where I launch my boat and she started right up. It looked like someone set off a massive smokescreen for about 2 minutes then it actually started to burn pretty clean. The idle was a little rough, I expect it to improve after I open it up for a few minutes on the open water.

    The bilge works properly now, maybe because of the new battery?

    The display is still out. "Disconnect the MFD for a couple of hours." Just pull it out of the purple foam thing? Should it see a 12v constant? "split the electrical box and check the fuse" I tried to open this thing and the second bolt wanted to strip out. I got scared and put the 1st one back in. Any tips?

    Thanks for your help, this would be much harder without all of the tips on your forum.

  9. #9
    Water Bum Rodneyae's Avatar
    Join Date
    Dec 2006
    Location
    Roanoke, Va
    Posts
    3,083
    Lots of smoke on start up is normal. Oil leaks from the lines and pump into the crankcase when they sit. Mine dose it every saterday after it has been sitting for the work week.

    R.

  10. #10

    Join Date
    Mar 2007
    Location
    Nashville, TN
    Posts
    25
    so I guess I should expect smoke after a decade... Any advice on opening the black box?

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 SLT 780 questions
    By BBCaprice in forum Polaris Open Discussion
    Replies: 13
    Last Post: 05-14-2007, 10:25 AM
  2. slt 780 dies part II
    By rbridges in forum Polaris Open Discussion
    Replies: 7
    Last Post: 05-12-2007, 06:38 PM
  3. slt 780 dies when turning left
    By rbridges in forum Polaris Open Discussion
    Replies: 17
    Last Post: 05-12-2007, 01:57 PM
  4. Help, SLT 780 problem(s)
    By tcboss429 in forum Polaris Open Discussion
    Replies: 10
    Last Post: 05-07-2007, 03:36 PM
  5. HELP slt 780
    By rbridges in forum Polaris Open Discussion
    Replies: 8
    Last Post: 05-04-2007, 09:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •