Results 1 to 8 of 8
  1. #1

    weird problem with turbo not spooling up

    Wondering if anyone can throw some light on this problem i have as i think i have tried everything.When i start the ski and wot it goes like stink untill i release the throttle and it wont rev by 3000 rpm.The only way i can get the revs up again is either by going over large waves so less water at the impellor or putting in reverse and letting the revs climb,which as soon as it hits 3,500 it of like a rocket.i do not have any fault codes showing up and on the trailor she revs out no problem.My turbo is a new one two years ago and is free enough and also the wastegate is loose enough. I have tried a new set of plugs new wastegate solenoid and also put a spring on the wastegate lever thinking it could of been the gate not closing properly.When the turbo spins up it goes great so if i keep high revs up she is fine. Any help is much appreciated the problem sound similar to a previous post on here from noidea except my revs stay under 3,500 the same symptoms as a stuck turbo which it isnt thanks Stevie w


  2. #2
    NOIDEA's Avatar
    Join Date
    Mar 2013
    Location
    South Africa
    Posts
    230
    +1
    18
    I had exactly the same problem with my ski also with no codes. The problem is when the waste gate actuator gets hot it starts to become sticky at certain points. Sometimes my ski wouldn't turn more then 3000 rpm also. At the end of the day it was the waste gate that didn't close all the way and sometimes stuck in the full open position . My waste gate was lose and looked fine even when testing with a syringe, but after allot of troubleshooting the waste gate was the problem. So to make sure the waste gate closes all the way I installed an extra spring.

    Click image for larger version. 

Name:	20130531_153615.jpg 
Views:	295 
Size:	73.0 KB 
ID:	303248

  3. #3

    Tried that

    Quote Originally Posted by NOIDEA View Post
    I had exactly the same problem with my ski also with no codes. The problem is when the waste gate actuator gets hot it starts to become sticky at certain points. Sometimes my ski wouldn't turn more then 3000 rpm also. At the end of the day it was the waste gate that didn't close all the way and sometimes stuck in the full open position . My waste gate was lose and looked fine even when testing with a syringe, but after allot of troubleshooting the waste gate was the problem. So to make sure the waste gate closes all the way I installed an extra spring.

    Click image for larger version. 

Name:	20130531_153615.jpg 
Views:	295 
Size:	73.0 KB 
ID:	303248
    Ok i did give that a try but after some more poking about i removed the turbo and about half a litre of water came out the exhaust side so that makes sense with the going over waves etc problem is where is the water coming from theres none in the oil so is it most likely the exhaust manifold and can i remove it without removing the engine Stevie

  4. #4
    AWA MEMBER
    Join Date
    Jan 2008
    Location
    Currituck, North Carolina, United States
    Posts
    4,616
    +1
    247
    Quote Originally Posted by thegasman34 View Post
    Quote Originally Posted by NOIDEA View Post
    I had exactly the same problem with my ski also with no codes. The problem is when the waste gate actuator gets hot it starts to become sticky at certain points. Sometimes my ski wouldn't turn more then 3000 rpm also. At the end of the day it was the waste gate that didn't close all the way and sometimes stuck in the full open position . My waste gate was lose and looked fine even when testing with a syringe, but after allot of troubleshooting the waste gate was the problem. So to make sure the waste gate closes all the way I installed an extra spring.

    Click image for larger version. 

Name:	20130531_153615.jpg 
Views:	295 
Size:	73.0 KB 
ID:	303248
    Ok i did give that a try but after some more poking about i removed the turbo and about half a litre of water came out the exhaust side so that makes sense with the going over waves etc problem is where is the water coming from theres none in the oil so is it most likely the exhaust manifold and can i remove it without removing the engine Stevie


    Nope, you will need to pull motor......or remove cylinder head

  5. #5

    removal of manifold

    Quote Originally Posted by RickWhite View Post
    Quote Originally Posted by thegasman34 View Post
    Quote Originally Posted by NOIDEA View Post
    I had exactly the same problem with my ski also with no codes. The problem is when the waste gate actuator gets hot it starts to become sticky at certain points. Sometimes my ski wouldn't turn more then 3000 rpm also. At the end of the day it was the waste gate that didn't close all the way and sometimes stuck in the full open position . My waste gate was lose and looked fine even when testing with a syringe, but after allot of troubleshooting the waste gate was the problem. So to make sure the waste gate closes all the way I installed an extra spring.

    Click image for larger version. 

Name:	20130531_153615.jpg 
Views:	295 
Size:	73.0 KB 
ID:	303248
    Ok i did give that a try but after some more poking about i removed the turbo and about half a litre of water came out the exhaust side so that makes sense with the going over waves etc problem is where is the water coming from theres none in the oil so is it most likely the exhaust manifold and can i remove it without removing the engine Stevie


    Nope, you will need to pull motor......or remove cylinder head
    EH wrong information mate you can remove the exhaust manifold in situ only took a couple of hours so alot better than pulling the motor or removing the cylinder head.pressure tested the manifold and water is peeing out the exhaust side hence the now mily oil.Anyone know where i can get another one second hand or am i best buying new from discount honda parts.Thanks for all input cheers

  6. #6
    AWA MEMBER
    Join Date
    Jan 2008
    Location
    Currituck, North Carolina, United States
    Posts
    4,616
    +1
    247
    I coulden't get mine out when it split and leaked, removed turbo wastegatethe, coulden't get past the hull sides.......if you could have removed mine that would have been a big help to me

  7. #7
    was it an r12x and what jammed it i just removed the turbo and exhaust and it slid out no problem with some of the longer manifold bolts in place

  8. #8
    AWA MEMBER
    Join Date
    Jan 2008
    Location
    Currituck, North Carolina, United States
    Posts
    4,616
    +1
    247
    it was on a F12X.....my R12x never had that problem

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Acceleration problem with turbo?
    By DBINX in forum Honda Performance
    Replies: 4
    Last Post: 06-14-2014, 03:00 PM
  2. Honda Aquatrax R-12X 2007 problem with Turbo and water infiltration
    By Pierre-Luc in forum Honda Open Discussion
    Replies: 2
    Last Post: 03-04-2012, 06:33 AM
  3. Weird problem with 95 slx 780
    By Kliped in forum Polaris Open Discussion
    Replies: 5
    Last Post: 07-30-2009, 09:23 PM
  4. What ignition for GPR? Weird problem with R-D CDI
    By Robsauto2 in forum Yamaha PWC Performance (2-stroke)
    Replies: 12
    Last Post: 07-19-2006, 06:23 AM
  5. Weird problem with ski this past weekend
    By carbuff91 in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 05-20-2006, 06:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •