Results 1 to 9 of 9
  1. #1

    1997 sl900 i got in on trade

    so i got this ski with the elctrical box apart and wires unplugged. i looked into it and found where everything was supposed to go and it fired up! idles pretty good. revs pretty good but not to the rev limit. i took it to the water and you have to hold it floored for about 15 seconds and it will finally plan up and if you let of the throttle to slowly cruise it almost seems like it is flooding itself out. it does this everytime you try to take off. it also is very hard to start and you have to go full throttle with the choke onto start it and then turn off the choke it stays running. it will idle fine through the water. im lost, carb issue? has good compression.


  2. #2
    Miglater's Avatar
    Join Date
    Apr 2013
    Location
    Howell, MI
    Posts
    424
    +1
    25
    Does it have good spark on all 3 cylinders? The elec. box being open when u got it may point twards stator/cdi issue, It may have the old ignition and that could be failing. Looking at the number on the cdi box inside the elec. box will tell if u have old style or updated ignition.

  3. #3
    Quote Originally Posted by duneriders13 View Post
    so i got this ski with the elctrical box apart and wires unplugged. i looked into it and found where everything was supposed to go and it fired up! idles pretty good. revs pretty good but not to the rev limit. i took it to the water and you have to hold it floored for about 15 seconds and it will finally plan up and if you let of the throttle to slowly cruise it almost seems like it is flooding itself out. it does this everytime you try to take off. it also is very hard to start and you have to go full throttle with the choke onto start it and then turn off the choke it stays running. it will idle fine through the water. im lost, carb issue? has good compression.
    Where did you find the wiring diagram? I have been looking online for hours and can't find it.. I have a 96 sl900 that i'm trying to rewire and can't find where they all go

  4. #4
    i just used my slx 1050 i had, alomst the same wiring. it had the seat and it was covered. very clean un the seat. It has good spark on all cylinders

  5. #5
    Miglater's Avatar
    Join Date
    Apr 2013
    Location
    Howell, MI
    Posts
    424
    +1
    25
    Are you using fresh gas?

    Good spark and compression, gotta be carbs/fuel then, does it have grey fuel lines? if so replace em. Clean the carbs. Clean filter element in water separator.

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    See my signature links. Do the fuel system and carb maintenance.

    Check and maintain all the other stuff while you are waiting for the genuine OEM carb rebuild kits to arrive.

  7. #7
    can i get a link to your link?

  8. #8
    actually re checked compression and it was 95 100 95........time for a rebuild i guess. know where to get a cheap topend rebuild?

  9. #9
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Quote Originally Posted by duneriders13 View Post
    can i get a link to your link?
    Try the Red, bold, underlined "Click here" on the bottom of K447s post....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1997 XP wont start in water Runs fine on trailer
    By dirtnap in forum 2-Stroke Performance
    Replies: 1
    Last Post: 07-28-2016, 05:46 PM
  2. Considering trading in on 14 RXTX
    By ashnic in forum 4-Tec Performance
    Replies: 10
    Last Post: 03-13-2015, 10:25 AM
  3. 1997 Polaris sl900 weak spark in center cylinder
    By Scotts900 in forum Polaris PWC Performance
    Replies: 9
    Last Post: 12-24-2014, 09:02 PM
  4. Repair 2 stroke or trade in on 4 stroke???
    By butch708 in forum Yamaha Open Discussion
    Replies: 7
    Last Post: 06-05-2013, 09:37 PM
  5. My RXP got sold on ebay
    By nitro rxp in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 09-04-2005, 09:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •