Results 1 to 6 of 6
  1. #1
    Tjdriver's Avatar
    Join Date
    May 2012
    Location
    Eglin AFB
    Posts
    485
    +1
    4

    Genesis limp mode

    Besides temp sensor and reverse, what else would cause limp mode? No red light or warning message on MFD.

    My genesis decided it wants to run in limp mode. It won't rev above 3,500-4000.

    The last time I was on it was 2 weekends ago and it ran fine. Nothing out of the ordinary.


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,601
    +1
    1,276
    You sure it is electronically limited, not some other cause?

    Will it rev above 4000 out of the water?

    Cylinder compression good?

    Intake reeds - any blowback up the throttle bodies?

  3. #3
    Tjdriver's Avatar
    Join Date
    May 2012
    Location
    Eglin AFB
    Posts
    485
    +1
    4
    I only ran it on the trailer in the yard. Yesterday was the first time I fired it up since riding a couple weekends ago. It did flash reverse one time so I hit the reverse and the warning went off, but it would still not rev past 4k. Temp sensor and rev are the only 2 things I know of that will limit the rpms.

    I hoped that you guys would know of something else I should be checking on. Hopefully I will have some time to work on it this afternoon. I had about 30 min to spare last night so I couldn't troubleshoot it. I'm wondering if its still the rev, but I'm not getting a warning indication.

    I'm thinking of removing the reverse bucket and linkage since it's so dang slow. My buddy's rev on his seadoo is stupid fast. Mine is geriatric. lol

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,601
    +1
    1,276
    PERC electric reverse isn't fast acting, I prefer the manual reverse lever on the 2002 Virage.

    The Reverse warning 'flashing' on suggests something is wrong. Perhaps a wire is shorting, or the PERC switch array is internally dirty or failing.

    Look for wires rubbing or damaged wires to the temp sensor, the reverse connector, possibly inside the reverse box, and of course inside the electrical box.

    It might have nothing to do with 'RPM limiter' and be an ignition system problem. Loose wire, failing stator, CDI...

  5. #5
    Tjdriver's Avatar
    Join Date
    May 2012
    Location
    Eglin AFB
    Posts
    485
    +1
    4
    I unplugged the temp sensor yesterday and no change. That was the original problem when I picked up the Genesis over a year ago so that was my first go to.

    Once I hit the rev button for 1-2 sec the warning message extenguished. I will mess with it when I get off work.

  6. #6
    Tjdriver's Avatar
    Join Date
    May 2012
    Location
    Eglin AFB
    Posts
    485
    +1
    4
    Fixed, sort of. lol. I unplugged the reverse wiring connector and she went over 4k. I drug the ski down to the boat ramp and bam!, 7130 rpms. Didn't test run it, but did run it for a few minutes. When I got home I pulled the reverse linkage and bucket and left the plug discod. I'll eventually get another rev module, but i'm in no hurry.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. polaris genesis water leak and limp mode help
    By hot83chevy in forum Polaris How To & FAQs
    Replies: 21
    Last Post: 05-12-2011, 11:22 PM
  2. Limp mode on a 97 STS.
    By ccassone in forum 2-Stroke Performance
    Replies: 2
    Last Post: 08-29-2009, 07:43 AM
  3. gas level limp mode ?
    By Bone1050 in forum Polaris Open Discussion
    Replies: 11
    Last Post: 03-22-2007, 06:58 PM
  4. limp mode
    By tommy33mac in forum Polaris How To & FAQs
    Replies: 13
    Last Post: 03-21-2007, 09:23 PM
  5. limp mode vs over of fuel
    By andy95'slx780 in forum Polaris PWC Performance
    Replies: 1
    Last Post: 10-02-2006, 04:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •