Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1

    ZXI 1100 Bilge pump questions

    i have a 2001 zxi 1100, i noticed that when i play around on the ski i take on an large amount of water... not from just riding, i tend to submerge my ski underwater from time to time. I just recently got it running great, and now have found a problem that if i put my drain plug in and submerge my ski it take on a ton of water in the hull, pretty sure its due to the seal on the seat not sealing great... i "thought" my ski came with the Venturi bilge pump stock. after the other day i realized that it does not... anyways i was wondering which is the best automatic bilge pump, where should i put my exit hole, and what size hole do i need to make for a 3/4 bilge pump(im assuming 3/4... just want to be sure)? this is the pump im looking at... http://www.academy.com/webapp/wcs/st...e+pump&Ntk=All
    thanks for any input,

    Shawn.


  2. #2
    Don't pee in my Pool 150ofUltra's Avatar
    Join Date
    May 2010
    Location
    Ft. Myers, FL
    Posts
    103
    You should have the pump pressure bilge. My 900zxi did. Check for a clog.
    That bilge should be fine. Yeah, 3/4" hole. I bought one of those mutli size drill bits. it costs a good bit, but has come in handy else were. Here's a link to my install on my Ultra150. There's a link for the switch I used. I bought my inline fuse at Oreilly's, 10amp.

    http://www.greenhulk.net/forums/showthread.php?t=197338

  3. #3
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,007
    +1
    282
    Here's what your bilge system should look like: http://www.powersedge.com/pages/OemP.../C19C1977F3145

    Sometimes the hose can split, which makes it totally ineffective.

  4. #4
    yeah i looked at the hose coming from the pump housing and followed it and it looks like its leading to the motor.... regaurdless i would feel more comfortable with the auto bilge incase i have a bad seal.

  5. #5
    Don't pee in my Pool 150ofUltra's Avatar
    Join Date
    May 2010
    Location
    Ft. Myers, FL
    Posts
    103
    download the manual if you don't have one.

    http://ultra150.yuku.com/topic/2878#.UbgGRJxbNCB

  6. #6
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,007
    +1
    282
    Quote Originally Posted by ShawnTX View Post
    yeah i looked at the hose coming from the pump housing and followed it and it looks like its leading to the motor.... regaurdless i would feel more comfortable with the auto bilge incase i have a bad seal.
    Yes, there are two hoses. One supplies cooling water to the engine, the other sucks water from the bilge pickup.

  7. #7
    yeah I know, my bilge pump hose is running to the bottom of my air intake.... I just installed an auto electric one. hopefully problem solved

  8. #8
    also, does anyone know where I can get an extended nozzle?

  9. #9
    Don't pee in my Pool 150ofUltra's Avatar
    Join Date
    May 2010
    Location
    Ft. Myers, FL
    Posts
    103

  10. #10
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,007
    +1
    282
    Quote Originally Posted by ShawnTX View Post
    yeah I know, my bilge pump hose is running to the bottom of my air intake.... I just installed an auto electric one. hopefully problem solved
    Huh???

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. bilge pump question
    By skoepp in forum 4-Tec Performance
    Replies: 9
    Last Post: 09-09-2008, 11:13 AM
  2. Dumb Guy Bilge Pump Question
    By LS2000 Cop in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 04-08-2008, 08:38 PM
  3. Bilge pump question 98slxh
    By tryintolearn in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 07-18-2007, 10:54 AM
  4. 1995 Polaris sl750 Bilge pump question .
    By smittyj77 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 05-29-2007, 12:47 AM
  5. Bilge Pump Questions
    By Piney in forum Sea Doo Open Discussion
    Replies: 20
    Last Post: 03-18-2006, 09:33 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •