Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 30
  1. #1
    AWA MEMBER
    Join Date
    Jan 2008
    Location
    Currituck, North Carolina, United States
    Posts
    4,616
    +1
    247

    My clutch does not free spin, what causes this on a 09' clutch?

    My SC does not free spin, it rotates with engine, but when off can't turn wheel any way.....still boosts up


  2. #2
    sprag is shot. Change it before going out again. You can do some serious damage running it this way now.

  3. #3
    AWA MEMBER
    Join Date
    Jan 2008
    Location
    Currituck, North Carolina, United States
    Posts
    4,616
    +1
    247
    It made some strange noise before going out I have 88hrs now all modified.......Thanks

  4. #4
    no worries, gus was discussing this with me last week. He said that with it locked up, you could possibly snap the shaft next and tAke out the whole housing with it. Im sure he will chime in, its early yet;0)

  5. #5
    AWA MEMBER
    Join Date
    Jan 2008
    Location
    Currituck, North Carolina, United States
    Posts
    4,616
    +1
    247
    Yea I was told not to run it anymore......thanks for the help.......maybe someone will chime in on what happened to sprag to make it lock and not free spin.....I thought they break and free spin both directions.... I noticed it when I shut down and didn't hear the SC free spin and wind down....

  6. #6
    His locked up to, its how those eliptical one way rollers wear that causes that......
    Mine is startng to chirp intermittently and will need to be changed soon too. Its an 09 with 61 hrs. Hoping to the summer out of it and then change it. I listen to for the spool down everytime I turn it off.

  7. #7
    AWA MEMBER
    Join Date
    Jan 2008
    Location
    Currituck, North Carolina, United States
    Posts
    4,616
    +1
    247
    Yea I was hoping mine would have made it till September.....lol too hot to be working on a ski now....LOL

  8. #8
    big john's Avatar
    Join Date
    Sep 2010
    Location
    Cocoa Beach, Florida, United States
    Posts
    3,395
    +1
    598
    too hot ?????? wussy !!!!! ive got a 2012 style clutch and idler gear with low hrs i'll let go cheap

  9. #9
    Whats that whistling noise? jtskier11's Avatar
    Join Date
    Sep 2007
    Location
    Right side of Kansas
    Posts
    4,342
    +1
    87
    Sprags over cammed and the elements are probably stuck in the cage. When you get the clutch out, pop the snap ring and washer out that are covering the element and see how it looks. It may have grenaded and the sprags are all jammed inside there.

  10. #10
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    535
    When the cage breaks in pieces. the clutch sticks and won't free wheel.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. what causes this to happen??
    By Full_Throttle in forum Yamaha PWC Performance (2-stroke)
    Replies: 19
    Last Post: 03-11-2008, 08:55 AM
  2. what causes this to happen????
    By Full_Throttle in forum Yamaha PWC Performance (2-stroke)
    Replies: 22
    Last Post: 02-05-2008, 01:36 AM
  3. ? What caused this damage
    By thrasher63 in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 07-21-2007, 04:27 PM
  4. What is this on my RXP?
    By vidbuster in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 05-11-2007, 09:44 PM
  5. Whats causing this?
    By porksword in forum Yamaha PWC Performance (2-stroke)
    Replies: 10
    Last Post: 08-13-2006, 01:42 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •