Results 1 to 6 of 6
  1. #1
    Just purchased this week, a 2007 FX HO with the Riva stage 1 kit. I have a couple questions.

    1. The speedometer does not work, previous owner said because of the Riva kit. Although I know the speedometer is fair at best telling actual speed, I would like it to work. It's the owner correct that the Riva kit caused this?

    2. The previous owner mentioned after the Riva kit, the ski "took a hard right turn at full speed" a couple times. One time breaking a guys collar bone. He said he shimmed the ride plate to slow it down a bit and everything was fine afterwards.

    3. From idle to full throttle, should I be hitting the rev limiter or should it hook up well enough with the Riva kit?

    Thanks so much!
    It's nice to get back on a ski after my 8 yeah hiatus..
    Last edited by cjldad; 06-14-2013 at 09:17 AM.


  2. #2
    (Crickets chirping)

  3. #3
    powerstroke specialist mikegp's Avatar
    Join Date
    Mar 2011
    Posts
    2,529
    +1
    190
    I do not believe the Riva kit has nothing to do with the speedo, have you inspect the sensor at the ride plate? follow the wire make sure its not cut or damage ,and plug into the display .
    regarding the hard right turn , it happen to me on my own ski and it almost kill me , how did I solve it , I install a oem sho ride plate , and Riva intake grate, hasn't happen anymore.

  4. #4
    powerstroke specialist mikegp's Avatar
    Join Date
    Mar 2011
    Posts
    2,529
    +1
    190
    when you power up the ski , by the remote or just hitting the star button , does the needle go all the way up and down?

  5. #5
    Thanks Mike.. I did inspect the wheel and it seems to operate just fine. It gives a reading, just not correct.. Just on the short test ride I took it may be about half of what it should be reading.

    When I unlock the ski the needle does go full and back. I assume this is good since that's the way it works on the Yamaha bikes..

  6. #6
    powerstroke specialist mikegp's Avatar
    Join Date
    Mar 2011
    Posts
    2,529
    +1
    190
    try spraying some wd40 at the wheel. it maybe dirty inside and see what happens.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2007 FX HO... question...
    By Mandinga22 in forum Yamaha PWC Performance (4-stroke)
    Replies: 10
    Last Post: 02-05-2011, 04:09 PM
  2. 2007 FX HO CRUISER w/ 25 hours
    By Islandtime in forum Yamaha Classifieds
    Replies: 2
    Last Post: 07-23-2008, 08:31 AM
  3. 2007 FX-HO Question
    By jimyed in forum Yamaha Open Discussion
    Replies: 2
    Last Post: 02-08-2008, 04:40 PM
  4. 2007 FX HO Question
    By GM Killer 5.0 in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 05-29-2007, 02:39 PM
  5. 2006 vs 2007 FX HO Cruiser cover
    By jb_turner in forum Yamaha Open Discussion
    Replies: 3
    Last Post: 04-07-2007, 10:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •