Results 1 to 2 of 2
  1. #1

    Angry 1999 XL 1200LTD won't start

    Hi Everyone,

    I had my ski out last week. Started no problem after less than 5 minutes just cut out on me. Restarted several times but died immediately,then it wouldn't even turn over. When I press start it just hums. The battery is new this season. When I got home I put it on a trickle charger just to be sure. It still just hums when I hit the start button. I don't have a battery tester so I can't check the battery. Any help will be appreciated.


  2. #2
    Join Date
    Jan 2010
    New Jersey
    check your compression first.....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1999 1200LTD Still Wont Start - Very Puzzled
    By wags in forum Yamaha PWC Performance (2-stroke)
    Replies: 15
    Last Post: 08-06-2012, 09:19 PM
  2. 1999 genesis won't start when hot
    By stump in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 07-06-2011, 07:10 PM
  3. Won't start. Code P-1656 Help!
    By mattpm07 in forum 4-Tec Performance
    Replies: 7
    Last Post: 09-11-2006, 11:26 PM
  4. Ski won't start...
    By Yellow93 in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 05-30-2006, 11:10 PM
  5. RXP won't start!
    By rxpblast in forum 4-Tec Performance
    Replies: 15
    Last Post: 07-12-2005, 03:28 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts