Results 1 to 5 of 5
  1. #1
    Seakid's Avatar
    Join Date
    Jun 2012
    Location
    East Texas
    Posts
    442
    +1
    9

    1989 ts 650 no spark firing

    . Everything works the engine turning but has 120 psi on one and 90 psi on one will need top end rebuild. But want to see it runs before start taking top end apart. She wont start and there no spark so replace cdi still no sprak. Tried another cdi and still same. Make it three cdi in row that has no firing.

    Any idea?


  2. #2
    Seakid's Avatar
    Join Date
    Jun 2012
    Location
    East Texas
    Posts
    442
    +1
    9
    They did firing like two times then after no firing at all.

  3. #3
    Don't pee in my Pool 150ofUltra's Avatar
    Join Date
    May 2010
    Location
    Ft. Myers, FL
    Posts
    103
    Check for voltage coming out of your cdi to the coil. if the cdi is sending power then it could be your coils. if it not, then the problem might lie in your stator not charging the coil or telling it to fire.

  4. #4

    Join Date
    Mar 2012
    Location
    Midwest City, OK
    Posts
    107
    Check all your ground wires & clean your contacts on your stop/start switch. Mine had intermittent spark until I did that.

  5. #5
    hi seakid im having the same issue on a 650ts thinking on checking the stator next , i already changed plugs leads and cdi box , im not too sure on how to check the stator any help would be appreciated , how did you get on with yours

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1994 sl 650 No Spark
    By Nic2011 in forum Polaris Projects
    Replies: 13
    Last Post: 07-20-2014, 11:42 PM
  2. New Ski Owner - 1994 GSX 650 - No spark
    By johnnystang in forum 2-Stroke Performance
    Replies: 0
    Last Post: 07-28-2010, 08:13 AM
  3. 93 SL 650 no spark problems
    By tip87 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 02-22-2009, 06:48 PM
  4. Sl 650 NO spark!
    By Parker Creighton in forum Polaris How To & FAQs
    Replies: 11
    Last Post: 07-15-2008, 06:37 PM
  5. sl 650 no spark
    By scottr2200 in forum Polaris Open Discussion
    Replies: 8
    Last Post: 09-13-2007, 11:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •