Results 1 to 4 of 4
  1. #1

    Exclamation why won't this thing run right?

    I was given a 1992 seadoo spi. It runs great when it is out of the water. As soon as I try to accelerate it bogs and chugs. The machine has been sitting for a year and the gas is probably bad but I would think that would make it run the same when it is out of the water too. Any help would be great.


  2. #2
    wotxxxsd's Avatar
    Join Date
    May 2012
    Old fuel and needs the carb rebuilt.
    Carbs need rebuilt after 6-8 months of sitting...
    I'd start there...

  3. #3
    If i knew,...I wouldn't ask sea-one's Avatar
    Join Date
    Aug 2009
    Dont put any fuel cleaners in the gas , it only ruins the carb components jmo

  4. #4
    your internal carb filters are clogged. clean those and replace your fuel lines while you are at it

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. HELP: Yamaha VX110 Won't Run Right
    By bahama in forum Yamaha How To & FAQs
    Replies: 3
    Last Post: 12-19-2008, 06:22 PM
  2. RXP won't run right after mods - Limp Home Mode?
    By snowrunner in forum 4-Tec Performance
    Replies: 16
    Last Post: 06-03-2008, 08:55 PM
  3. Now i remember why i bought the thing
    By Pettee in forum Sea Doo Open Discussion
    Replies: 19
    Last Post: 03-13-2006, 11:32 AM
  4. Ski eye - Can I put this thing on my RXP?
    By Jeff C in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 07-28-2005, 09:53 PM
  5. Oil Level question , this thing mixes me up :(
    By rxp_boy in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-23-2005, 10:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts