Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 24
  1. #1

    2012 RXP-X 260 problem

    This is my first time dealing with a 4 stroke or supercharged ski, but last summer I bought an rxp and only put 6 hours on it all summer and it ran fine the whole time. I winterized it and stored it in my heated shop all winter, and last week before I started using it I asked the dealer if it was worth getting the "10 hour" service then instead of waiting until I got another 4 hours on it and he said that was fine. So I had them service last week, and now today was the first time I rode it this year. It started up fine and was fine idling through the no wake zone, then when I accelerated it was good for about 20 seconds at high speed then if I held the throttle steady the rpms started varying widely up and down and so did speed, then it just started to steadily decrease in speed. I brought it back down to an idle, and it seemed fine again, then I tried to give it some gas and it started revving up then stalled and shut off. I tried to start it 2 times and it wouldn't start and the check engine light came on. I was getting ready to call SeaTow and waited 10 minutes and then it barely started again and I limped it in at idle, when I reached the channel I tried giving it a little gas one more time to see if it was still happening and when it started to rev up it bogged and almost stalled again. It seemed like the issues would start to occur right as it started to produce boost. I will be calling my dealer when he's open on tuesday and have him take a look, but has anyone experienced this before or know what might be causing it? Thanks in advance for any advice


  2. #2
    Tiny's Avatar
    Join Date
    Sep 2006
    Location
    The Atl
    Posts
    3,561
    +1
    578
    Did you try new plugs????

  3. #3
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    You have old gas in it.
    You need to suck the old fuel out and put fresh in.
    If fuel sit for more than 4-5 months its junk.
    Put fresh fuel in it and run a double dose of fuel Injector cleaner thru it.
    Once you have good fuel then replace the spark plugs.
    Old fuel ruins good plugs.
    Your issue is very common.
    Don't take it to the stealership and have them rip you off.

  4. #4
    C Doo's Avatar
    Join Date
    Mar 2007
    Location
    Perth Australia
    Posts
    387
    +1
    20
    agreed. check plugs, get new fuel... and just hope your stock IC hasn't gone, which will have fried the throttle body

  5. #5
    I could try new plugs, but at the end of the season I left it with about half a tank which I added fuel stabilizer too, and then last week I topped off the tank with fresh gas. I always add fuel stabilizer to my boats and skis before letting them sit for the winter.

  6. #6
    dnielsen's Avatar
    Join Date
    May 2008
    Location
    Shreveport, Louisiana
    Posts
    2,018
    +1
    94
    New plugs and ride on!

  7. #7
    just tried it today in the driveway and it wont even start, I may try gas and plugs before the dealer but if that doesn't work hopefully it inst too much more

  8. #8
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Fuel stabilizer doesn't work on this new crap fuel.
    This corn based fuel attracts moisture when it sits.
    Stabilizer doesn't prevent this from happening...

  9. #9
    for the last 10 years stabilizer has worked fine on my boat which has a 56 gallon tank running into a 496ci mercruiser, and the same fuel is in my sxr and that has worked fine the last 3 years at the begining of the season, same with my camaro that I put into storage from November to April every year. What do you do at the end of the year, you cant leave the tank empty or you will get condensation in it.

  10. #10
    Well the dealer called this morning and said that there was a leak in the intercooler that was causing water to leak into the cylinders and fouled the plugs. they said they were replacing the intercooler, and that this is supposedly a known problem by seadoo and the intercooler they are replacing it with is supposedly updated in some way to prevent this.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2012 RXP-X 260 break in process
    By pelf421 in forum 4-Tec Performance
    Replies: 32
    Last Post: 01-05-2013, 08:36 AM
  2. Good Price for a 2012 Rxp-X 260?
    By lake-dune in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 06-27-2012, 07:02 PM
  3. 2012 RXP-X 260 Plastics
    By superman in forum Sea Doo Build Threads
    Replies: 11
    Last Post: 03-28-2012, 03:46 PM
  4. Replies: 0
    Last Post: 02-21-2012, 10:23 PM
  5. Replies: 0
    Last Post: 02-21-2012, 10:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •