Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19
  1. #1

    Ultra-150 will not go past 5-mph

    I just bought my son a 2002 Ultra-150 has 46 hours in excellent condition was stored since 2009 when the gentlemen that owned it passed. Even thought it was not put in the water they checked it and winterized it every year. Compression checked out and the engine is so clean it looks news new. The issue I put it in the water for the first time will not go past 5-mph. The engine revs but feels like it pushing against something that is stuck. I was afraid to push it to hard, If I leave it at idle it cruises right along at 5-mph. I think it is the jet pump, if it was seized would this be the symptoms. I'm thinking even if there was an engine problem considering the power it would go past five. It is almost like there is a safety on the thing...



    Thanks, NOHYPE!


  2. #2
    Dialga's Avatar
    Join Date
    May 2013
    Location
    California
    Posts
    99
    +1
    8
    Welcome to the forum Nohype!

    Well isn't that a bummer. Oh k lets see... have you changed the spark plugs? Bad plugs usually cause it to pull but not accelerate and will often cause it to make a jerking sound but won't go faster than about 5 MPH or so. If it isn't the spark plugs just take it to a mechanic and have them look at it.

    Cheers!

  3. #3
    CJ's gpr's Avatar
    Join Date
    Aug 2012
    Location
    Long Island
    Posts
    685
    +1
    34
    could be a very bad case of cavitation, you may need a new impeller

  4. #4
    Ski Hacks MG's Avatar
    Join Date
    Apr 2013
    Location
    Georgia
    Posts
    5,253
    +1
    990
    Have you inspected the pump tunnel, drive shaft, intake and impeller? Sounds like you have trash or debris in one of the 4.

  5. #5
    Quote Originally Posted by CCW View Post
    Have you inspected the pump tunnel, drive shaft, intake and impeller? Sounds like you have trash or debris in one of the 4.

    Yes, everything looks new one of the reason i bought it, should the impeller spin freely. Or can only the engine make it spin...

  6. #6
    Thanks.... I have a new set, they looked good before I put it in the water maybe they fouled. It has not been run in awhile. The engine does feel like a caged animal maybe it is the plugs... Thanks

  7. #7
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,014
    +1
    285
    Quote Originally Posted by Nohype! View Post
    Yes, everything looks new one of the reason i bought it, should the impeller spin freely. Or can only the engine make it spin...
    No, the impeller will be hard to turn unless the spark plugs are removed.

  8. #8
    CJ's gpr's Avatar
    Join Date
    Aug 2012
    Location
    Long Island
    Posts
    685
    +1
    34
    the impeller shaft is locked into the driveshaft coming out of the engine. its possible to spin it but it would be just as hard as spinning a driveshaft. like steve said, you should be able to if the plugs are out.

    it does sound like theres debris in the tunnel though, have you looked down it with a flash light?

  9. #9

    Not Yet

    Quote Originally Posted by CJ's gpr View Post
    the impeller shaft is locked into the driveshaft coming out of the engine. its possible to spin it but it would be just as hard as spinning a driveshaft. like steve said, you should be able to if the plugs are out.

    it does sound like theres debris in the tunnel though, have you looked down it with a flash light?
    No I have not, I have it on a boat hoist so I can easily check. What would happen if say the impeller drive jammed, is the driveshaft spinning against rubber coupling to the pump. Thanks for your help I appreciate it....

  10. #10
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,014
    +1
    285
    If the impeller were jammed, say with a rock, the driveshaft would not turn and the engine wouldn't crank.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 300X will not go past 60 MPH
    By silverback2002 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 9
    Last Post: 04-27-2015, 06:14 AM
  2. Ultra 150 will not start..
    By zrtman in forum Kawasaki How To & FAQs
    Replies: 15
    Last Post: 10-09-2013, 06:52 AM
  3. Ultra 250X Problems - Rough Idle, will not go past 25MPH, runs rough
    By troye in forum Kawasaki PWC Performance (4-stroke)
    Replies: 21
    Last Post: 10-09-2012, 10:47 AM
  4. 1997 SL780 Stumbles around 3K, and will not go past 4.5k
    By boomanch1967 in forum Polaris Open Discussion
    Replies: 7
    Last Post: 07-30-2012, 05:26 PM
  5. MSX 150 Will Not go over 2900 RPMS
    By rtburns in forum MSX/Matrix
    Replies: 3
    Last Post: 07-01-2009, 10:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •