Results 1 to 6 of 6
  1. #1

    Join Date
    May 2012
    Location
    McKinney Texas
    Posts
    140
    +1
    5

    Unhappy Need Advice about DFI and an EMM

    I sent in my FICHT EMM to DFI about a month ago. Got it back within about two weeks. Did the about 1.5 hour install, and it did the same thing(no start). I switch EMMs between my two skis, and the problem following the EMM. They replaced the C89, and upgraded the EMM.

    I sent it back to them, and got it back in about 1 1/2 weeks. They said the regulator was bad. They did not check that part of the EMM before, as they did not know the battery light was flashing.

    Did the install again, took it out Sunday. It lasted about 10 minutes before it died again. Same issue Battery light flashing, and not starting.

    They are closed today. Any advice? Should I give them another shot at it or buy a new EMM and dispute the charge?
    Could the stator be causing the failure?

    PS this is on an Kawasaki 1100 STX DI. I posted it in the Polaris forum, as there seems to be more FICHT and DFI talk here.


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,601
    +1
    1,277
    I would call DFI when they are next open and see what they say.

  3. #3
    ThrottleOut's Avatar
    Join Date
    Aug 2011
    Location
    Corning, NY
    Posts
    727
    +1
    29
    It may be worthwhile to check the readings of the coils on the stator. I know the Polaris and Kawasaki specs are slightly different but it might be worth checking to see where they are now just to verify you don't have a short or anything like that. But like K447 said, call DFI and tell them what it's doing and try to go from there. They may have some suggestions. If the EMM from your running ski still fires up the other one I'd lean towards there still being an issue with the EMM.

  4. #4

    Join Date
    May 2012
    Location
    McKinney Texas
    Posts
    140
    +1
    5
    I do have a bad stator. I found an open circuit. Upon removal I found a broken wire where it goes into the stator. I have ordered an replacement stator. The EMM is on the way back to DFI for repair. Does the fun ever stop? Is is normal for an open circuit to cause EMM failure?

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,601
    +1
    1,277
    Quote Originally Posted by keithg1964 View Post
    I do have a bad stator. I found an open circuit. Upon removal I found a broken wire where it goes into the stator. I have ordered an replacement stator. The EMM is on the way back to DFI for repair. Does the fun ever stop? Is is normal for an open circuit to cause EMM failure?
    How did you decide the EMM was bad if you did not have a good stator to test with?

  6. #6

    Join Date
    May 2012
    Location
    McKinney Texas
    Posts
    140
    +1
    5
    Quote Originally Posted by K447 View Post
    Quote Originally Posted by keithg1964 View Post
    I do have a bad stator. I found an open circuit. Upon removal I found a broken wire where it goes into the stator. I have ordered an replacement stator. The EMM is on the way back to DFI for repair. Does the fun ever stop? Is is normal for an open circuit to cause EMM failure?
    How did you decide the EMM was bad if you did not have a good stator to test with?
    I have two skis.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. EMM Repair Longevity - Calling those who have had DFI repair an EMM!
    By ThrottleOut in forum Polaris Open Discussion
    Replies: 80
    Last Post: 06-14-2013, 08:18 AM
  2. Need Advice about Modded Pump I just purchased....
    By GTLaser in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-10-2010, 04:44 PM
  3. need advice about fuel filter for 1200 gpr year 2000
    By noshowallgo in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 10-29-2008, 08:18 PM
  4. Need a rxp hull and an 97xp hull.
    By BobOnThis in forum Sea Doo Classifieds
    Replies: 3
    Last Post: 04-28-2008, 10:26 PM
  5. Need some advice about speeds and differences!!
    By gkya blazin in forum 4-Tec Performance
    Replies: 29
    Last Post: 09-25-2007, 05:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •