Results 1 to 5 of 5
  1. #1

    Join Date
    Aug 2012
    Location
    Thunder Bay, ON CA
    Posts
    9

    95 SLT 750 Problems

    Bought ski last year. Redid 1 cylinder with pistons rings etc. Put in triple fuel pump, new fuel lines, rebuilt carbs and installed new reeds. Took out for first time last week and ran good. Had battery issues (seems to drain battery when sitting). Put new battery and took out to camp again. Ran good for a couple hours then when went to use again would not rev over 4700 - 4900 rpm. (Same issue as when purchased). Any ideas? Noticed said lo power on MFD when loaded up. (Never ran long when not running well.) Would low battery cause problems and what would drain battery when sitting? Any suggestions would be greatly appreciated.
    Thanks


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Bad LR voltage regulator module or a short in the magneto stator charging coil will drain the battery.

    Ohm check the stator.

    Disconnect the LR module Yellow and Red/Purple wires. See if the battery drain goes away. If yes, replace LR module.

    LoPR on the MFD display means the battery voltage is very weak. If this happens when engine is running then the battery charging system is not working properly.

  3. #3

    Join Date
    Aug 2012
    Location
    Thunder Bay, ON CA
    Posts
    9
    Thanks for the quick reply. Will low power cause the ski to run poorly as well?

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Quote Originally Posted by Moose00 View Post
    Thanks for the quick reply. Will low power cause the ski to run poorly as well?
    You may have more than one problem happening at the same time. Not unusual for a machine that has just been put back into service after storage.

    Certainly you need to solve the battery drain problem and get the charging system working.

    I cannot say whether a LoPR condition (low battery voltage when running) would invoke RPM limiting on that engine (working from memory here).

  5. #5
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Quote Originally Posted by K447 View Post
    I cannot say whether a LoPR condition (low battery voltage when running) would invoke RPM limiting on that engine (working from memory here).
    Should not as the 95 750 CDIs do not have a limiter function, unless the CDI was updated with a 780 model.....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 95 Polaris SLT 750 Problems
    By Moose00 in forum Polaris Open Discussion
    Replies: 12
    Last Post: 07-19-2015, 09:42 PM
  2. 95 slt 750 fuel problem
    By johnny7 in forum Polaris Open Discussion
    Replies: 32
    Last Post: 06-16-2010, 09:20 AM
  3. fuel primer for 95' slt 750
    By xplayer2885 in forum Polaris How To & FAQs
    Replies: 7
    Last Post: 08-03-2008, 09:13 AM
  4. TDR water box for 95 slt 750
    By xplayer2885 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 01-01-2007, 12:25 PM
  5. 95 slt 750 wont charge
    By The Joker in forum Polaris How To & FAQs
    Replies: 8
    Last Post: 12-13-2006, 03:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •