Results 1 to 2 of 2

Thread: need some help

  1. #1

    need some help

    hey all,
    i have been seaching the web for days looking for some help from people that have had the same problem with no luck so i am hoping you guys can give me some guidance. I have a 98 Kawasaki 1100 STX with triple Keihin CDCV carbs. They were receintly rebuilt along with the fuel pump and a primer kit installed....Here is the problem.I can get it started alot easier now with the primer kit but once its running it begins to idial kinda high and begins to smoke.this is out of the water with the hose connected...any ideas on how i can adjust or what the problem is?

  2. #2
    steve45's Avatar
    Join Date
    Feb 2008
    Smoking when it's first started is normal. Smoking will be dramatically reduced when running fast in the water.

    How fast is it running? Have you tried adjusting the idle speed screw? If it's running really fast, you probably have a leak on the intake side. Look for loose carb mounting hardware and intake manifold nuts.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need some help guys, Lost 500rpm
    By CRS in forum 4-Tec Performance
    Replies: 13
    Last Post: 05-15-2006, 05:24 PM
  2. need some help
    By Pettee in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 05-12-2006, 05:44 PM
  3. Need some help ?
    By RXP04 in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 04-20-2006, 04:36 PM
  4. Need some help planning a trip.
    By Pistonwash in forum Yamaha Open Discussion
    Replies: 21
    Last Post: 03-15-2006, 06:58 PM
  5. SeaDoo 3D (need some help)
    By MARKUS in forum 2-Stroke Performance
    Replies: 21
    Last Post: 02-09-2006, 05:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts