Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    Did you install Fizzle HE IC yet??

    1) Did you find that neither of the elbow couplers were quite the right ID for the TB on the intake? I can pinch them and get slack on both....they're nearly 1/4in ID larger than the hose I've been using forever. But, I cant use my old hose with all this new piping/Fizzle IC bracket angle. 2) How did you install the polished elbow pipe...did you put the long side of the elbow to the IC, or to the SC outlet? Mine is long side to IC right now, but it's kinda leaving the short end slightly cocked inside the straight coupler SC hose (hair too much angle of a pipe). Yes, I'm fitting everything before anything is tightened, including the bracket to the transom. I'm half tempted to just use ALL of my old shitty piping and couplers, but then that means I just paid about $300 just for a Fizzle bracket


  2. #2
    Boost-A-Holic's Avatar
    Join Date
    Jul 2012
    Location
    Dallas, Texas, United States
    Posts
    1,173
    +1
    94
    had no problems with the install of my HE. Everything lined up fine i just noticed theres not much room for mistake. The pipe from the charger to the IC is just barely long enough. You have to get it in-between the couplers just right or the pipe pops off one side real easily. Other than that no problems really.

  3. #3
    RXPJAY's Avatar
    Join Date
    Nov 2012
    Location
    Sudbury, Ontario
    Posts
    847
    +1
    93
    Mine all fit ok. Really tight fit but all lined up after some swearing and windex for lube!

  4. #4
    Do you have the long side of the polished elbow towards to IC? And did you notice any access slack in the hose diameter when you torqued the clamps? Not too much slack, but again its nearly 1/4in diameter larger than my other hose with is perfect fit.

    Edit: Shit, I don't need any lube for my hoses.

  5. #5
    RXPJAY's Avatar
    Join Date
    Nov 2012
    Location
    Sudbury, Ontario
    Posts
    847
    +1
    93
    Quote Originally Posted by blkturbo! View Post
    Do you have the long side of the polished elbow towards to IC? And did you notice any access slack in the hose diameter when you torqued the clamps? Not too much slack, but again its nearly 1/4in diameter larger than my other hose with is perfect fit.

    Edit: Shit, I don't need any lube for my hoses.
    Blkturbo, I could send you picks of mine all set up in the morning if u like. My hoses where all tight. The 45deg solid pipe pipe and two straight couplers go from sc the ic and the straight solid pipe and two 45 couplings go from ic to tb.

  6. #6
    RXPJAY's Avatar
    Join Date
    Nov 2012
    Location
    Sudbury, Ontario
    Posts
    847
    +1
    93
    Yes long side at ic

  7. #7
    RXPJAY's Avatar
    Join Date
    Nov 2012
    Location
    Sudbury, Ontario
    Posts
    847
    +1
    93
    Also the ic inlets are larger. Two of the straight couplings have one side larger for this. The other side smaller to clamp to the tubing

  8. #8
    83.0 @ 8400 jhill19's Avatar
    Join Date
    Jul 2010
    Location
    Teays Valley, West Virginia
    Posts
    2,800
    +1
    81
    Pictures would probably help

  9. #9
    I believe that's how I had everything mocked up earlier! Thanks for looking and the pics offer!
    I wonder if your hose-to-TB fitment was a hair loose (1/4in too large ID). I just hate relying on a T-bolt to suck up on that little slack vs it being a more snug fit....because it makes me paranoid that I'll be left with maybe a tiny boost leak there, plus stresses the hose under the slightly pinching clamp.
    My original hose that I've been using on the other IC is a perfect, but it's not quite the right angle for all these new Fizzle parts, so using that is out.

    Furthermore, back on that polished elbow:
    The way mine is fitting at it's best (so far) is with the short end of the elbow getting angled down into the SC hose a little too much - cocked a little inside the coupler. This makes me wonder if there's any altering to the flow of the boost charge leaving the SC and into the IC. Seems like that cocked elbow inside the coupler would create plenty of turbulence since the edge of it isn't sitting naturally inside the coupler.

    I don't know how much of this I'm over thinking these issues, if at all. I just know my other kit isn't anything expensive, yet it all fits perfectly once you dick around with the IC a little.

  10. #10
    Quote Originally Posted by jhill19 View Post
    Pictures would probably help
    If you mean me, the pics I could take unfortunately wouldn't show the issues I'm concerned with (unless I just had something totally installed wrong). But I'm pretty sure I had it all mocked up like Jay has his.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Fizzle HE IC water routing
    By TheGunMan in forum 4-Tec Performance
    Replies: 10
    Last Post: 06-05-2014, 08:11 PM
  2. FS New Fizzle HE IC Black Powder coated
    By Ocman in forum Sea Doo Classifieds
    Replies: 5
    Last Post: 09-26-2013, 06:10 AM
  3. Installing Fizzle HE IC - yellow washer in the pump
    By TheGunMan in forum 4-Tec Performance
    Replies: 10
    Last Post: 09-13-2013, 04:44 PM
  4. FS Fizzle HE IC Bracket.
    By Water4fire in forum Sea Doo Classifieds
    Replies: 4
    Last Post: 04-11-2013, 05:25 PM
  5. Replies: 2
    Last Post: 07-19-2005, 10:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •