Results 1 to 2 of 2
  1. #1
    VdeKock's Avatar
    Join Date
    Nov 2012
    USA - NL

    GP1300 Steering cable problem

    How is this cable working/connected at the back of the hull outside,
    the last part where the cable is sliding true is loose,
    it doenst stay tight to the hull.

    the cable comes out of the pipe, and the rubber is also gone...

    do i need a hole new cable.?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	image.jpg 
Views:	31 
Size:	59.6 KB 
ID:	304302   Click image for larger version. 

Name:	image.jpg 
Views:	25 
Size:	54.9 KB 
ID:	304303  

  2. #2
    powerstroke specialist mikegp's Avatar
    Join Date
    Mar 2011
    it will work , but star looking for one . that rubber is to prevent water entering the cable.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Steering Cable Bolt Problem 06 rxp
    By Sea-Yaa in forum 4-Tec Performance
    Replies: 1
    Last Post: 05-05-2011, 09:37 PM
  2. Extending the stock trim and steering cable for 2" exte
    By Insanediego Joe in forum Yamaha PWC Performance (2-stroke)
    Replies: 17
    Last Post: 11-01-2007, 05:55 PM
  3. slt780 steering cable to slx780
    By andy95'slx780 in forum Polaris PWC Performance
    Replies: 1
    Last Post: 10-28-2006, 07:01 PM
  4. Steering cable and stock tube ....
    By Flyer in forum 4-Tec Performance
    Replies: 7
    Last Post: 02-26-2006, 12:31 PM
  5. Steering Cable Tip
    By 1FastTrespiper in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 08-26-2005, 08:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts