Results 1 to 10 of 10
  1. #1
    usamps's Avatar
    Join Date
    Jul 2012
    Location
    fayetteville, nc
    Posts
    84
    +1
    1

    05 rxp pump support fins

    i sent a impellor off to impros. They did a great job on getting it back to specs after it met several rocks. I put it back on the ski with a new wear ring. I was doing about 68 or so. i can only do around 62 now. The plasctic fins on the support are damaged , i read on here somewhere to file them down. could that be what caused the 5 plus mph drop.


  2. #2
    shrabber's Avatar
    Join Date
    Apr 2008
    Location
    Jacksonville, FL
    Posts
    5,305
    +1
    376
    If the prop looks fine I would check the pitch ( I had my buddies prop on my bench he sent to them a year ago and before I repitched every blade had a different pitch). I Would Inspect the wear ring if you sucked up rocks the wear ring got thrashed. Did you change/inspect your wear ring.

  3. #3
    usamps's Avatar
    Join Date
    Jul 2012
    Location
    fayetteville, nc
    Posts
    84
    +1
    1
    i bouight a new wear ring, its a 159mm from impros.I thought they were the best arond. i hope the prop is back to specs.

  4. #4
    shrabber's Avatar
    Join Date
    Apr 2008
    Location
    Jacksonville, FL
    Posts
    5,305
    +1
    376
    not to discredit them nobody is perfect just trying to point you in a helpful direction. make sure your pump seal and your pump is tight

  5. #5
    Thats a lot of speed difference. Before going on a wild goose chase, I would call impros and clarify anything and everything about the original pitch and what was done during repair. I believe they keep it documented.
    They are a reputable company and the owner is really cool. I'd call them with any concern you have at all. Then chase other ideas or possibilities. I'm not so sure those plastic pump fins will scrub that much speed.

  6. #6
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    What RPMS are you pulling???Did you inspect the pump shoe for any other damage??Hows the intake grate??Is it damage free and flush with the ride plate???Is everything tight and torqued to spec??.if your RPMs are the same as before then i wouldnt think your prop is off that much...BUT you do definatly need to get them broken sharks teeth out,they can and will cause all kinds of havoc with cavatation and speed....If all those check out ok then I agree with Sean, call impros or see if they sent you a spec sheet..

  7. #7
    usamps's Avatar
    Join Date
    Jul 2012
    Location
    fayetteville, nc
    Posts
    84
    +1
    1
    i took off the pump today and filed all the fins down flush. It seemed to run a little better after that. I called solas first, the fins are to designed to break up air bubbles before it goes into the prop and pump. My rpm's are only around 7850, give ro take 50. i think that is where my spped got lost. i have taken the whole part apart twice and dont see anything wrong.

  8. #8
    RXPJAY's Avatar
    Join Date
    Nov 2012
    Location
    Sudbury, Ontario
    Posts
    847
    +1
    93
    I would think its the prop pitch. Your short 300 rpm there. That translates to speed for sure.

  9. #9
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Quote Originally Posted by usamps View Post
    i took off the pump today and filed all the fins down flush. It seemed to run a little better after that. I called solas first, the fins are to designed to break up air bubbles before it goes into the prop and pump. My rpm's are only around 7850, give ro take 50. i think that is where my spped got lost. i have taken the whole part apart twice and dont see anything wrong.

    Sounds to me like your prop was tweeked,and when you sent it to impros to be reconditioned they set it back to the original pitch...you may need to have some prop tweeking done to get your RPMs and speed back.....this is why it is nice to have a prop gauge if your sit is modded,that way if you tear a prop up you can always reset it to what you had in it before.....

  10. #10
    usamps's Avatar
    Join Date
    Jul 2012
    Location
    fayetteville, nc
    Posts
    84
    +1
    1
    it was never tweaked. i bought a stage one kit from jerry and put it on. So its original.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB - Parts 05 RXP Pump Support
    By lilman573 in forum Sea Doo 4Tec Skis
    Replies: 0
    Last Post: 09-10-2012, 09:29 AM
  2. FS New rxp pump support # 271001251 intake shoe inlet pump
    By Maulin Marto in forum Sea Doo Classifieds
    Replies: 3
    Last Post: 04-15-2010, 08:48 AM
  3. 05 rxp pump shoe replacement
    By tchies in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 10-24-2009, 09:14 PM
  4. WTB: RXP Pump Support
    By 05Limited in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 04-24-2008, 01:18 PM
  5. do pump support fins have any purpose
    By macattack in forum 4-Tec Performance
    Replies: 17
    Last Post: 07-10-2005, 09:56 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •