Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1

    Join Date
    Jun 2013
    Location
    Fort Worth, TX
    Posts
    7

    My New(to me) 1999 Ultra 150

    ...
    Last edited by crusher44x; 06-30-2013 at 10:16 PM.


  2. #2
    bryantjopplin's Avatar
    Join Date
    Jun 2012
    Location
    Shreveport, LA
    Posts
    2,436
    +1
    163
    You didn't happen to pick that up near new Boston did you?

  3. #3

    Join Date
    Jun 2013
    Location
    Fort Worth, TX
    Posts
    7
    No, I picked it up in Flowermound, TX.

    Sorry I just realized I should have posted this thread in the "Projects" section! I'm new to this site!

  4. #4
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,014
    +1
    284
    Welcome aboard, Crusher! Always nice to have a fellow Texan! The stand looks pretty good, my first stand was made of PVC pipe. I've got a couple of 'real' work stands, now.

    There's a place called HotRods that can fix your crank. I've heard good and bad about them. Good used cranks for these engines are scarce because they tend to blow up. I'd be tempted to buy a new OEM crank, but they're expensive ($940). SBT rebuilds cranks, but I wouldn't use one.

  5. #5
    Pwcengines.com rebuilt an ultra crank for me using wsm parts and weldes the pins in for 495. Very pleased with tge workmanship. Hope you got it for very cheap since your looking at a good price for rebuild since it needs a crank, pistons, casing and cylinder.

    Good luck

  6. #6

    Join Date
    Jun 2013
    Location
    Fort Worth, TX
    Posts
    7
    ...
    Last edited by crusher44x; 06-30-2013 at 10:17 PM.

  7. #7
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,014
    +1
    284
    From what I understand, it's usually a piston failure. Not sure if it's rings catching in a port, or the skirt cracking; but debris gets into the bottom and and the rod knocks the pieces out the bottom. There was one guy that had the rod go out the bottom of the hull!!!

    I think the best thing to do is use OEM parts and plan to do a top overhaul every 200 hours, if not sooner.

    Make sure you replace the oil lines because they get brittle and crack when they get old. Remove the display and seal the wires and plug on the back with 3M 5200 because it will leak and ruin the display if you flip the 'Ski. The Triple Pisser Mod is a very worthwhile thing to do, as is the inlet water strainer and bilge pump. The jet pump needs to be overhauled more often than other 'Skis, but if you use the later kit with the extra seal, you can improve it's lifespan. Watch for water leaking around the driveshaft seal.

    The Ultra 150 is a GREAT 'Ski, you just have to take care of it. Don't let newbies ride it!

  8. #8
    bryantjopplin's Avatar
    Join Date
    Jun 2012
    Location
    Shreveport, LA
    Posts
    2,436
    +1
    163
    Steve he said he was new to ski's. Lol

  9. #9
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,014
    +1
    284
    Quote Originally Posted by bryantjopplin View Post
    Steve he said he was new to ski's. Lol
    And your point would be...?

  10. #10
    600 isent bad. We grabbed a 2000 for 450 which needed a crank, pistons and two cylinders. Were in the ski for about 2100 with buying the ski. Take care of these skis and run an ounce per gallon ontop of your injection and you'll have no issues.

    While you have the engine out replace the drive shaft coupler for piece of mind. Have had them go bad and ski almost sink.

    Tripple pisser is a necessary mod.

    Good luck!

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New (to me) 2007 Ultra 250X questions...
    By boxlaxman in forum Kawasaki PWC Performance (4-stroke)
    Replies: 6
    Last Post: 08-05-2010, 03:38 AM
  2. Replies: 4
    Last Post: 09-05-2009, 01:35 AM
  3. My new to me tow vehicle
    By KeithKman in forum Open Discussion
    Replies: 10
    Last Post: 08-10-2009, 08:40 PM
  4. I have a couple questions about my "new to me"ski
    By pclynch1974 in forum Polaris Open Discussion
    Replies: 14
    Last Post: 06-03-2008, 03:50 PM
  5. My new (to me) 1998 Pro 785
    By hyoctane23 in forum Polaris Open Discussion
    Replies: 58
    Last Post: 04-08-2008, 12:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •