Results 1 to 8 of 8
  1. #1
    cbrich's Avatar
    Join Date
    Nov 2006
    Location
    Around Lake Travis
    Posts
    1,374
    +1
    1

    Wedge Installation

    Ok I got the nozzle off and notice 2 internal return lines at the top of the nozzle and pump. The wedge has the holes for these lines, should I use silcone to seal up the wedge to the nozzle or just install the wedge dry? What are these return lines for?


  2. #2
    I'm kind of a big deal SeanCucf's Avatar
    Join Date
    Jul 2006
    Location
    Oldsmar, FL
    Posts
    1,852
    those are the siphon tubes....(bilge system)....i believe riva calls for silicone, and i'm pretty sure i siliconed the entire wedge...

  3. #3
    cbrich's Avatar
    Join Date
    Nov 2006
    Location
    Around Lake Travis
    Posts
    1,374
    +1
    1
    I was kinda figuring that, guess I will have to go out and get some silcone since the tube I have is rock hard.

  4. #4
    GOTTA PAY TO PLAY!!! rocko672's Avatar
    Join Date
    Sep 2006
    Location
    Lutcher, La.
    Posts
    260
    when i put my wedge on Jerry said to just put it on with no silicone but i'm sure a little wont hurt

  5. #5
    cbrich's Avatar
    Join Date
    Nov 2006
    Location
    Around Lake Travis
    Posts
    1,374
    +1
    1
    Quote Originally Posted by rocko672 View Post
    when i put my wedge on Jerry said to just put it on with no silicone but i'm sure a little wont hurt

    If Jerry said no silicone, then no silicone it is.

  6. #6
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    silicone is not needed....BUT....I always put a SLIM coat of it (around holes and entire contact surface), reason is if you take a bunch of water from wave jumping is provides a little better suction for siphoning....otherwise, us normal riders don't need it....

  7. #7
    HOSS's Avatar
    Join Date
    Aug 2005
    Location
    Kenner, LA
    Posts
    4,759
    +1
    29
    skim the wedge with RTV

  8. #8
    cbrich's Avatar
    Join Date
    Nov 2006
    Location
    Around Lake Travis
    Posts
    1,374
    +1
    1
    I skimmed the side of the wedge facing the pump since the nozzle side has o-rings. I also installed the Riva grate and the bad ass sticker that came in the box, I expect the sticker to give me at least another 1 mph maybe 2. I will finish up this round mods with the reverse bucket mod.

    Thanks to everyone who gave me advise with this install.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Wedge Install Question
    By tomgtv in forum Kawasaki PWC Performance (4-stroke)
    Replies: 9
    Last Post: 03-10-2007, 07:37 PM
  2. Steering alignment after wedge install
    By excess in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-18-2006, 04:46 PM
  3. Wedge install...
    By Alaska05RXT in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 04-23-2006, 11:48 PM
  4. Wrong Wedge Install ?
    By Kinchyle in forum 4-Tec Performance
    Replies: 7
    Last Post: 07-13-2005, 05:41 PM
  5. Wedge installed and lost 50 rpm
    By Kinchyle in forum 4-Tec Performance
    Replies: 1
    Last Post: 07-01-2005, 08:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •