Results 1 to 8 of 8
  1. #1
    ozzychua's Avatar
    Join Date
    Feb 2012
    Location
    Singapore
    Posts
    16
    +1
    1

    Need help on RXP260X

    After 2 months of sleep, today I started my craft and there are fees errors code appear. P060E. P1611. P1615. P1619 AND P1622. The craft can start but engine can'tgo higher. No control of RPM. need lots of advise and help please. Thank you.


  2. #2
    Pete1027's Avatar
    Join Date
    Jul 2012
    Location
    Adelaide, AUSTRALIA
    Posts
    474
    +1
    15
    Try connection on throttle body.

  3. #3
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    It does sound like something is unplugged or a maybe something ate some wires during the 2 months it sat.
    My buddy had a rat eat some wires and his ski threw many codes until he replaced the wiring harness.
    If its under warranty bring it to the stealership..

  4. #4
    ozzychua's Avatar
    Join Date
    Feb 2012
    Location
    Singapore
    Posts
    16
    +1
    1
    Thanks mates. Wire connection all check. Change new map sensor and still the same. Too bad warranty is over.

  5. #5
    GRF + DashPac:) seadoo02xp's Avatar
    Join Date
    Apr 2005
    Location
    MO
    Posts
    4,559
    +1
    948
    Is your ski bone stock? You don't have a tune Or stand alone ecu do you?

  6. #6
    ozzychua's Avatar
    Join Date
    Feb 2012
    Location
    Singapore
    Posts
    16
    +1
    1
    Quote Originally Posted by seadoo02xp View Post
    Is your ski bone stock? You don't have a tune Or stand alone ecu do you?
    Thanks mate, it's not stock. come with XX-charger / 4" filter, 1100cc injectors / RIVA Fuel Reg at 58psi static, Tune to 8650 using VN110 36 36165. Now AFR idealing at 22.5!! Faint! I suspect it's the map. But too much errors. Any advise? Again Thank you ALL for the reply. I don't know where to start from here.

  7. #7
    iron head's Avatar
    Join Date
    Aug 2006
    Location
    ONT CANADA
    Posts
    616
    +1
    2
    bad injectors there gum up

  8. #8
    GRF + DashPac:) seadoo02xp's Avatar
    Join Date
    Apr 2005
    Location
    MO
    Posts
    4,559
    +1
    948
    Quote Originally Posted by iron head View Post
    bad injectors there gum up
    +1 look into fuel delivery first

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. guys, I really need help on this one
    By maguyver in forum Yamaha Old School Skis
    Replies: 19
    Last Post: 02-11-2008, 10:08 PM
  2. Need Help on 02 virage 700cc
    By jeffholloway96 in forum Polaris How To & FAQs
    Replies: 13
    Last Post: 12-19-2007, 07:48 AM
  3. Need help on a 440!!
    By thesepaperwings in forum Kawasaki Open Discussion
    Replies: 1
    Last Post: 11-15-2007, 08:36 AM
  4. Need Help On Motor Mounds
    By wsony13 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 08-26-2007, 10:54 PM
  5. Replies: 11
    Last Post: 08-25-2006, 06:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •