Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
  1. #1
    Sigmarxt's Avatar
    Join Date
    Mar 2012
    Location
    Greece
    Posts
    396
    +1
    43

    Water in hull issue...

    Ok. Fired her up. Was hearing an almost unnoticeable whistle ..I thought it was the filter which I have moved up front..a couple of minute later the hull had water inside..(below SC). I emptied the water and started her up with seats off in order to spot where the water was coming from.. The engine was running with some vibration , rpms looked to have no problem and the ski was hardly moving... Water was filling the hull but could not spot from where..Stopped the ski and took it out...Any ideas?


  2. #2
    SELF27's Avatar
    Join Date
    May 2013
    Location
    Austin, TX
    Posts
    202
    +1
    16
    Check carbon seal on driveshaft. Make sure support ring is tight against carbon seal.

  3. #3
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Put the ski on the trailer and put some water inside the hull.
    Once you get water in it see where its leaking from.

  4. #4

    Join Date
    Nov 2012
    Location
    Belgrano, Distrito Federal, Argentina, Argentina
    Posts
    14

  5. #5
    Sigmarxt's Avatar
    Join Date
    Mar 2012
    Location
    Greece
    Posts
    396
    +1
    43
    Quote Originally Posted by SELF27 View Post
    Check carbon seal on driveshaft. Make sure support ring is tight against carbon seal.
    I will check it out.

  6. #6
    Sigmarxt's Avatar
    Join Date
    Mar 2012
    Location
    Greece
    Posts
    396
    +1
    43
    Quote Originally Posted by wotxxxsd View Post
    Put the ski on the trailer and put some water inside the hull.
    Once you get water in it see where its leaking from.
    Thanks for the tip...

  7. #7
    Sigmarxt's Avatar
    Join Date
    Mar 2012
    Location
    Greece
    Posts
    396
    +1
    43
    Also water in hull enters when I start the engine . Standing still in water there is no leak...

  8. #8
    Quote Originally Posted by wotxxxsd View Post
    Put the ski on the trailer and put some water inside the hull.
    Once you get water in it see where its leaking from.
    Agreed!!

  9. #9
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Check all your hoses and clamps too....you may have a hose that has come loose or off....

  10. #10
    Sigmarxt's Avatar
    Join Date
    Mar 2012
    Location
    Greece
    Posts
    396
    +1
    43
    Quote Originally Posted by Snoman View Post
    Check all your hoses and clamps too....you may have a hose that has come loose or off....
    What I am concerned is that the engine vibrates and although rpms go up the ski goes no more than 10 mph...as if as I had a cavitation issue never seen before!

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2006 rxp water in hull issue
    By missrxp in forum 4-Tec Performance
    Replies: 2
    Last Post: 09-06-2012, 10:45 PM
  2. Issues...03 GTX S/C Hesitation and water in hull
    By hfdmedic38 in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 07-08-2010, 10:52 AM
  3. Water in hull up to engine cover
    By jonstephens in forum 4-Tec Performance
    Replies: 20
    Last Post: 09-25-2005, 12:56 AM
  4. Alot of water in hull
    By Drake in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 07-26-2005, 07:42 PM
  5. RXP Water in Hull
    By jpwt62 in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-06-2005, 10:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •