Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1

    2005 STX 12F No fulel or spark to #1 and 4 cylinder

    I have a 2005 12F that I am nor getting spark to #1 and #4 cylinders. If I switch the plug from the #2 and #3 coil pack to the #1 and #4 coil pack I get spark and fuel. Camshaft and crankshaft position sensors are within specs. Wires all ring out fine from coil packs to ECM. Is there anything that I am missing other than replacing the ECU?


  2. #2
    Speedaddict's Avatar
    Join Date
    Dec 2005
    Location
    Florida
    Posts
    268
    +1
    2
    Any codes up on the dash?

    Did you try searching the forum before posting?

    I just bought an 05' 15F a week ago and thought I might use the motor in it before I tossed it and did the conversion.
    Its been a nightmare to get it to run right.
    Wires going to the igniter in the ecu from the coils were all
    melted together. The fuel pump wiring was damaged in corrosion.
    Tank full of deposits, injector #2 was clogged, fuel pump filter clogged, fuel pump was bad.
    I got it to run and idle on the trailer last night after I took care of all that.


    I will PM you later tonight with some useful diagrams and diag charts that might help you pin point the source of the problem.
    Also check out smokeysevin's thread: http://www.greenhulk.net/forums/showthread.php?t=186939

  3. +1 by:


  4. #3
    My name is Sean and I am addicted to STXs smokeysevin's Avatar
    Join Date
    May 2008
    Location
    Houston
    Posts
    4,485
    +1
    320
    Quote Originally Posted by Speedaddict View Post
    Any codes up on the dash?

    Did you try searching the forum before posting?

    I just bought an 05' 15F a week ago and thought I might use the motor in it before I tossed it and did the conversion.
    Its been a nightmare to get it to run right.
    Wires going to the igniter in the ecu from the coils were all
    melted together. The fuel pump wiring was damaged in corrosion.
    Tank full of deposits, injector #2 was clogged, fuel pump filter clogged, fuel pump was bad.
    I got it to run and idle on the trailer last night after I took care of all that.

    I will PM you later tonight with some useful diagrams and diag charts that might help you pin point the source of the problem.
    Also check out smokeysevin's thread: http://www.greenhulk.net/forums/showthread.php?t=186939
    Thanks for posting that, I hope it proves useful.

    I will try and update the thread with your ignition wire issues, did you notice what size fuse was in the harness?

    Sean

  5. #4
    Speedaddict's Avatar
    Join Date
    Dec 2005
    Location
    Florida
    Posts
    268
    +1
    2
    I didn't. Ill check tonight.
    At idle it rpms would fluctuate slightly. Monitored the fuel pressure for a few minutes noticed the fuel reg is done.
    Got rid of the stock reg, installed an Aeromotive regulator and made a mounting bracket for it.Taking it to the lake again on Friday. I decided I'm keeping the motor and turbocharging it over the next 6 months.
    Still stuck on what EMS to use...
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	photo.jpg 
Views:	53 
Size:	40.0 KB 
ID:	304824  

  6. #5
    My name is Sean and I am addicted to STXs smokeysevin's Avatar
    Join Date
    May 2008
    Location
    Houston
    Posts
    4,485
    +1
    320
    Quote Originally Posted by Speedaddict View Post
    I didn't. Ill check tonight.
    At idle it rpms would fluctuate slightly. Monitored the fuel pressure for a few minutes noticed the fuel reg is done.
    Got rid of the stock reg, installed an Aeromotive regulator and made a mounting bracket for it.Taking it to the lake again on Friday. I decided I'm keeping the motor and turbocharging it over the next 6 months.
    Still stuck on what EMS to use...
    What are your goals and budget? I am using a megasquirt 3 with ms3x card for my itb motor.

    Sean

  7. #6
    Speedaddict's Avatar
    Join Date
    Dec 2005
    Location
    Florida
    Posts
    268
    +1
    2
    As of right now...heres the list..

    Motor
    JE Pistons 9:5:1, Stock rods and Crank.
    Full Ferrea Valve Train
    STi Pink injectors (these are 550cc?)
    Still trying to find out what the breather mod is?
    Cams from the ZX12R??

    Pump
    Either the 250 or 300 pump...still trying to figure out if either will adapt easily or if they are even any different.....maybe Skat 12, 14 vein
    R&D intake grate and ride plate..gotta spend some time back there and see what can be done

    EMS
    It will be either AEM or MS3....COP....but at this point...I have red so much on your build and the MS3, that it blows my mind at all the possibilities for the price.

    I want the ski to make 325-350hp pump gas and be able to cruise around 20-25 miles on any given sunday..I know...I have alot of homework and reading to do.

  8. #7
    My name is Sean and I am addicted to STXs smokeysevin's Avatar
    Join Date
    May 2008
    Location
    Houston
    Posts
    4,485
    +1
    320
    The 250/300 pump fits with some work but it fits.

    For a rec ski you may want to consider just swapping a 250/260/300 motor, no tuning to do, no custom metalwork, and will run 78 even at stock boost on a 250 motor and will run pump fuel.

    For a turbo, 325-350 wouldnt be hard and you have a good start, make out a list of all the small parts such as fuel fittings, silicone connectors, wiring harness parts, and other items.

    The megasquirt system is almost limitless but it has a fairly steep learning curve, fortunately I have made most mistakes already and can help.

    My request would be to start a build thread in the project section and detail as much as possible, pictures are a bonus. Ill be happy to help however I can.

    Sean

  9. #8
    Speedaddict's Avatar
    Join Date
    Dec 2005
    Location
    Florida
    Posts
    268
    +1
    2
    Has anyone here documented a 15F build with the 300 or 260 motor?
    Looked thru the project section didn't find much but a few posts with no pics or dedicated threads.

  10. #9
    My name is Sean and I am addicted to STXs smokeysevin's Avatar
    Join Date
    May 2008
    Location
    Houston
    Posts
    4,485
    +1
    320
    Just the one that used a 250x motor by blackrxp.

    Sean

  11. #10
    Speedaddict's Avatar
    Join Date
    Dec 2005
    Location
    Florida
    Posts
    268
    +1
    2
    I was browsing thru his thread..then when I saw the holes on the sides, I suddenly found myself back on DIYAutotune
    When I start on it I will make a new thread. I am going to need all the help I can get. Especially with the EMS setup and config.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. where to buy a used or rebuilt motor for a 2005 stx 12f
    By hgantala in forum Kawasaki Open Discussion
    Replies: 6
    Last Post: 11-14-2015, 08:43 PM
  2. 2007 STX-12F No spark
    By termite68c in forum Kawasaki PWC Performance (4-stroke)
    Replies: 0
    Last Post: 07-17-2014, 12:08 PM
  3. Kawasaki 2005 stx 1200f no spark on coils
    By Giroux in forum Kawasaki PWC Performance (4-stroke)
    Replies: 0
    Last Post: 07-08-2014, 08:15 PM
  4. 05 STX 12F no fuel or spark to #1 & #4
    By Chris Sadler in forum Kawasaki Open Discussion
    Replies: 1
    Last Post: 08-08-2013, 11:30 PM
  5. 2005 STX 12f....no fuel
    By x2dad in forum Kawasaki PWC Performance (2-stroke)
    Replies: 0
    Last Post: 08-03-2007, 02:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •