Results 1 to 3 of 3
  1. #1

    '07 Aquatrax idling rough and turbo not engaging properly

    I've only been on the water a few times this season. On my first outing, after a few hours on the water, I noticed the engine was idling very rough. The RPMs were fluctuating up and down. Later, when I punched the throttle, I realized the turbo wasn't kicking in. After gassing it a bit, the turbo kicked in and the ski seemed to be idling fine. All was well for the rest of the day. The next time out, the same thing happened. I've done some research and someone suggested it could be a waste gate issue? Am planning to take the ski to the dealer tomorrow, as I feel this is likely beyond my abilities, and wanted to check in with you guys and get your opinions before I take it to the dealer. thanks

  2. #2
    Join Date
    Jan 2008
    Currituck, North Carolina, United States
    New set of plugs, seafoam in gas tank, fresh fuel

  3. #3
    jlfx car audio's Avatar
    Join Date
    Jul 2011
    jackson, TN
    If its stumbling during any type of acceleration is probably plugs ...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 4
    Last Post: 06-07-2011, 06:11 PM
  2. Engine running rough Turbo not kicking in.
    By RobertS in forum Honda How To & FAQs
    Replies: 4
    Last Post: 07-22-2010, 06:05 PM
  3. Antifreeze coming out of overflow and idle rough
    By IBADTON in forum 4-Tec Performance
    Replies: 14
    Last Post: 08-23-2009, 08:35 PM
  4. Ski quit running and starter will not engage??
    By Bryan K in forum Yamaha PWC Performance (2-stroke)
    Replies: 23
    Last Post: 07-15-2008, 10:27 AM
  5. 97 gtx engine missing/rough idle update and more issues
    By hotrod_sxty8 in forum 2-Stroke Performance
    Replies: 0
    Last Post: 06-09-2008, 08:42 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts