Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    Surges From Low To High Power; 2005 RXT

    2005 RXT, 215hp, 130-hours, supercharger rebuilt with updated kit at 70-hours. It responds to the throttle, but every one to two seconds it surges back and forth from low power to high power. Continual surging throughout the entire throttle range. It acts like a cylinder is cutting in and out. When is surges to low power, it runs rough and I feel vibration. When it surges to high power, it feels like it's running normal, and there is no unusual vibration. At idle, it runs rough and the exhaust has a strong smell. It's winterized every winter with Sta-bil added to the fuel. No fault codes are displayed. I plan to replace the plugs. If that doesn't fix the problem, what should I check next? After that, what should I check? Any help would be greatly appreciated. Thanks.


  2. #2

    Join Date
    Jul 2008
    Location
    Aurora Ontario Canada
    Posts
    360
    +1
    6
    Check the oil see if its milky or not.

  3. #3

    Join Date
    Sep 2012
    Location
    Lake Sunapee
    Posts
    45
    +1
    2
    Get the basics squared away.

    Drain/use up all of the treated gas.

    Change plugs. Check that all three look the same- if one is not like the others, swap the injector with that was on the goofy plug then recheck and see if that plug is now different.

    Do the same with coils if needed.

    Start there.

  4. #4
    The oil is NOT milky.

  5. #5
    Update - I changed the spark plugs, and hooked it up to the garden hose while on the trailer. It seemed to run just fine under these conditions. Next, I'll take it to the lake and see how it behaves while under load. The spark plugs all looked exactly alike... the tops of the overreaching arms were white, they were dry, and their were no signs of pitting, burning, or fouling.

  6. #6
    imp0ster's Avatar
    Join Date
    Dec 2011
    Location
    Palm Harbor, FL
    Posts
    5,037
    +1
    672
    bad gas. Fill up at a high volume station that cycles a lot of gas and use the same station every time

  7. #7
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    No codes, or alarms?

  8. #8
    If it is bad gas, and perhaps one or more of the fuel injectors has become SLIGHTLY clogged, what can I do to clean the injectors without having to remove them? I've heard about Sea Foam. I've heard about (liquid) fuel injector cleaners. What's best? Will they harm the engine? Any suggestions would be greatly appreciated. Thanks.

  9. #9
    No codes. No alarms.

  10. #10
    imp0ster's Avatar
    Join Date
    Dec 2011
    Location
    Palm Harbor, FL
    Posts
    5,037
    +1
    672
    fresh gas and a can of seafoam cleaned mine when I first bought it. Then OPAS damn near murdered me. Flog it. It wants to be flogged

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2005 rxt high compression, low rpm?
    By whosurpopi in forum 4-Tec Performance
    Replies: 14
    Last Post: 03-18-2016, 07:00 PM
  2. What are ideal AFRs for sho/svho low to high
    By Jmfmk3 in forum Yamaha PWC Performance (4-stroke)
    Replies: 3
    Last Post: 05-08-2015, 08:27 PM
  3. Moving from 2005 RXT to 2008 rxt-x
    By Viking24 in forum 4-Tec Performance
    Replies: 3
    Last Post: 01-21-2013, 11:40 PM
  4. GP1300R not performing from mid to high
    By scuubby in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 05-27-2008, 08:19 PM
  5. 2005 RXT - Season 1 to Stage 1
    By Kinchyle in forum 4-Tec Performance
    Replies: 16
    Last Post: 05-23-2006, 12:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •