Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    Turbo build and shaft stripped on the 2nd day out WTF.

    not sure what went wrong but i am only doing 15psi of boost, the shaft stripped and brand new skat-trak 15.5/22.5 damaged also. any other options out there besides stock shaft?

    Click image for larger version. 

Name:	photo1.jpg 
Views:	113 
Size:	38.9 KB 
ID:	304702
    Click image for larger version. 

Name:	photo.jpg 
Views:	124 
Size:	73.1 KB 
ID:	304703
    Click image for larger version. 

Name:	photo2.jpg 
Views:	121 
Size:	88.6 KB 
ID:	304704


  2. #2
    GRF + DashPac:) seadoo02xp's Avatar
    Join Date
    Apr 2005
    Location
    MO
    Posts
    4,559
    +1
    948
    Looks like your shaft wasn't far enough into the prop.

  3. +1 by:


  4. #3
    REID2168's Avatar
    Join Date
    Jun 2007
    Location
    My House
    Posts
    8,156
    +1
    241
    Quote Originally Posted by seadoo02xp View Post
    Looks like your shaft wasn't far enough into the prop.
    like the motor was a bit to far forward and the shaft had an extra 1/4" to 1/2" front to back movement and the shaft got to far forward in the prop and spun...........kinda what i was thinking....BUMMA!!!!


  5. #4
    aka my engine is not alight properly and sits to far forward?

  6. #5
    GRF + DashPac:) seadoo02xp's Avatar
    Join Date
    Apr 2005
    Location
    MO
    Posts
    4,559
    +1
    948
    Quote Originally Posted by DR2006RXP View Post
    aka my engine is not alight properly and sits to far forward?
    Yup

  7. #6
    not sure if the impeller part is salvageable it appears to be pressed in since it is not the same material, if it is removable them maybe i can make a new one and press it back in,

  8. #7
    got both impeller and shaft fixed, we managed to extract the inner gear from an old impeller and extract the damage one from the new impeller here are the results.
    Click image for larger version. 

Name:	photo(3).jpg 
Views:	159 
Size:	122.2 KB 
ID:	305278Click image for larger version. 

Name:	photo(4).jpg 
Views:	138 
Size:	41.0 KB 
ID:	305279Click image for larger version. 

Name:	photo(5).jpg 
Views:	135 
Size:	80.4 KB 
ID:	305282

  9. #8
    I have a friend that works as a Seadoo mechanic at a huge dealer. He is also a racer that has lots of credibility around here.

    This subject came up and he claimed that any time one of these skis sucks in a rock, you get this result. He did not know if this was by design to save pumps or was a design flaw in the new drive shafts. He told me that he had seen about 8 of these just this season.

    Andy

  10. #9
    Quote Originally Posted by whittlebeast View Post
    I have a friend that works as a Seadoo mechanic at a huge dealer. He is also a racer that has lots of credibility around here.

    This subject came up and he claimed that any time one of these skis sucks in a rock, you get this result. He did not know if this was by design to save pumps or was a design flaw in the new drive shafts. He told me that he had seen about 8 of these just this season.

    Andy
    Problem andy is that the impeller has not 1 ding on it ( so no rock not this time ( fingers crossed)), it was all narrowed down to a possible bad engine mount or misaligned engine, i should be back in the water in 1-2 days i got blue engine mounts from Rhaas so i should not have this issue again.

  11. #10
    this is the why it all almost went to hell 3 bad engine mounts.
    Click image for larger version. 

Name:	3 broken engine mounts.jpg 
Views:	80 
Size:	101.0 KB 
ID:	306235

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. ...and on the 7th day God created the Spitfire! For Sale
    By Insanediego Joe in forum Conversion Skis Classifieds
    Replies: 2230
    Last Post: 06-15-2015, 10:42 AM
  2. Replies: 17
    Last Post: 01-15-2012, 04:46 PM
  3. Any before and after results on the Riva 300x speed overide module?
    By jetdave56 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 67
    Last Post: 06-01-2011, 06:40 AM
  4. GPR bogged and just quit on the water
    By oldschool1921 in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 06-16-2009, 05:48 AM
  5. opening up and extra hole on the cowling what is the negative of doing that?
    By noshowallgo in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 11-01-2008, 06:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •