Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1

    SeaDoo GTX IS limited problem

    I was just wondering if anyone else out there is having this problem with their GTXis. The problem I have with mine is starting it. Ill hook up the battery, which is fully charged, and when I press the start button to let the gauges sweep and boot up everything is fine. When i put the key in, I hear the two beeps, but when I press the start button I hear a clicking sound and the gauges sweep again and blink rapidly. There are no error codes when this happens and I'm kind of getting fed up with bringing it back to the dealer ship. This will be my 4th trip to the dealer ship for this problem. Anyone else have a similar problem? BTW this problem will happen once in awhile. The ski will be fine for a couple months then it will randomly come back.


  2. #2
    Tiny's Avatar
    Join Date
    Sep 2006
    Location
    The Atl
    Posts
    3,561
    +1
    578
    What year model ski???

    Has the starter solenoid ever been replaced??

    How do you know it is a good battery??? Have you had it load tested????

    Are you properly tightening the battery cables????

  3. #3
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    It'd say its the starter solenoid if your battery is fully charged.
    If this is your 4th trip and they haven't replaced the starter solenoid then find a new dealership.

    Have your battery load tested.
    Batteries only last a max of 2 years.

  4. #4
    GasResearch-VT.SE's Avatar
    Join Date
    Nov 2012
    Location
    Melbourne, Australia
    Posts
    1,172
    +1
    207
    bad earth

  5. #5
    Tiny's Avatar
    Join Date
    Sep 2006
    Location
    The Atl
    Posts
    3,561
    +1
    578
    Quote Originally Posted by wotxxxsd View Post
    It'd say its the starter solenoid if your battery is fully charged.
    If this is your 4th trip and they haven't replaced the starter solenoid then find a new dealership.

    Have your battery load tested.
    Batteries only last a max of 2 years.
    Not totally true, I have 7 years out of an AGM Deka battery and a customer brought one in that he had 9 years out of......

  6. #6
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Damn..
    7 and 9 years out of a ski battery...
    That's some great luck..
    I do have a Riva gel battery that's going on 4 years but its my spare...

  7. #7
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,494
    +1
    476
    Quote Originally Posted by GasResearch-VT.SE View Post
    bad earth
    +1 check all grounds there are a few on the front of the motor

  8. #8
    myown1manarmy's Avatar
    Join Date
    May 2012
    Location
    Noblesville, Indiana, United States
    Posts
    164
    +1
    13
    starter solenoid - check your battery cables make sure their tight and grounded and make sure their not loose on the solenoid and starter then grab a starter solenoid its cheap and easy to replace

  9. #9
    HI pandellio21, look at my thread "user crapseadoo" posted on sunday 2/2/2014; my 2010 GTX IS has exactly the same problem BUT I have eliminated all electric issues except the starter motor which I have ordered and hope it will fix it.

  10. #10
    Any news on this mate, I think I'm having the same problem :/

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2010 GTX-is iBR Problems
    By Scarpa in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 12-02-2017, 02:24 AM
  2. SEADOO GTX IS Limited 2010
    By crapseadoo in forum 4-Tec Performance
    Replies: 9
    Last Post: 02-17-2014, 10:52 AM
  3. First time Jet-Ski buyer........2011 GTX iS Limited
    By DoneDunIt in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 05-27-2011, 11:17 AM
  4. Dealer won't give me my GTX iS Limited!!!!
    By ChitownSeadoo in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 05-22-2009, 10:26 PM
  5. Mileage of RXT-X 08 & GTX iS Limited 09
    By ChitownSeadoo in forum Sea Doo Open Discussion
    Replies: 17
    Last Post: 04-06-2009, 12:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •