Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1

    08 rxp-x 255 intercooler hoses blowing off

    I am fairly new to jetskis, this is my first ski and its an 08 rxpx 255 with 91 hours. I just had the sc rebuilt, and ski serviced to avoid it needing to be done mid summer at 100 hours. The ski is completely stock and have not had any mechanical issues with the ski to this point. On the first time out after the rebuild while running wot I heard a pop and lost propulsion. I had no warning indicators and motor ran normal but ski would only run about 10mph. Got ski home and found one of the hoses from the intercooler was blown off. Thinking it might have been left loose I checked hose made sure clamp was tight. There was a good amount of grease inside the hose so I cleaned all that out and took ski out for test ride. About 15 minutes in had same symptoms found hose blown off again. This has happened 3 times. Has anyone had this issue ? Any suggestions or advice would be appreciated

    Thanks


  2. #2
    CHAD IBADTON's Avatar
    Join Date
    Jul 2008
    Location
    on lake Harding AL
    Posts
    558
    +1
    34
    Get good clamps not worm clamps

  3. #3
    szt8b7's Avatar
    Join Date
    Jul 2010
    Location
    Shreveport, LA
    Posts
    661
    +1
    6
    Use T clamps instead of the worm gear type. I also had issues until I replaced the old hoses. The inside will get soft and just tear away. I replaced mine with silicone but know others have just put new stock hoses on and been OK.

  4. #4
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    There is some goop that you can put inside the hose that will help hold it on with a new hose clamp.
    Sorry I forgot the name of it but the stuff I used was orange in color.
    I've also heard of people using hair spray.

  5. #5
    I have the exact same ski nod hd the exact same problem a few times. The best thing to do is to redo all the clamping points on the ski. For whatever reason, it seems the simplest things......like good clamps, seems to be common problem. You figure if you buy a new ski for $10k and up, that the hoses wold stay on.

    Why I did was to take apart all the hoses and check the clamps. Then all the "high pressure" sides where the are more likely to pop off, is to add better clamps...as some of the others mentioned. With the hose of clean the mounting surface and maybe even use light emery cloth to rough it up and give it some grippy surface. Be careful not to let any dust get into critical areas. Then cleans the hoses properly...No Grease!...use a bit of dish soap when you want to put them back. Then get better clamps. Use either "T" bolts clamps or constant tension type. Forget those worm gear clamps ( see my post on Sudden Exhaust Problem)

    So far, since I changed / upgraded my clamps I have had no issues

    Hope this helps

  6. #6
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    With 91 hrs and the hose having greasy residue in it the hose is toast. Once it comes off the first time, it will continue to come off. My 08 PX did the same thing. I used to keep a spare around, they are only $39

    Oh, welcome to Greenhulk.

  7. #7
    I will order new hoses and better clamps so I dont have to worry about it

    Thanks for the help

  8. #8
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Quote Originally Posted by mbooth27 View Post
    I will order new hoses and better clamps so I dont have to worry about it

    Thanks for the help
    Sounds like your SCer seal was and/or is leaking too. I would pull the I/C and clean it out when replacing hoses. They get full of oil gunk from the leaking seal. Make sure the SCer is not leaking oil.

  9. +1 by:


  10. #9
    CHAD IBADTON's Avatar
    Join Date
    Jul 2008
    Location
    on lake Harding AL
    Posts
    558
    +1
    34
    Yes hair spray works after you get oil off
    . I use it on my truck 63 psi and it holds like super glue.

  11. +1 by:


  12. #10
    Where does all the grease on the hoses come from? The inside of the hose had grease as well as it was caked on the outside of the hose. Is it from leaking sc that have now been replaced during the rebuild or are there others that need to be checked?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 08 rxp x 255 Mods Intercooler Info order list
    By MartinsRxp in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-12-2014, 07:53 PM
  2. Jet Draft Intercooler with Blow off Valve kit now on sale!
    By Green Hulk in forum Yamaha PWC Performance (4-stroke)
    Replies: 0
    Last Post: 02-08-2011, 02:52 PM
  3. supercharger hose blowing off
    By idoodou in forum 4-Tec Performance
    Replies: 12
    Last Post: 11-04-2010, 11:07 AM
  4. 08 RXP-X intake hose blowing off?
    By DCoog in forum 4-Tec Performance
    Replies: 14
    Last Post: 06-29-2009, 09:11 PM
  5. Replies: 2
    Last Post: 05-04-2008, 09:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •