Results 1 to 7 of 7
  1. #1
    dpracing's Avatar
    Join Date
    Jan 2008
    Location
    Palm Beach, Florida
    Posts
    1,244
    +1
    246

    Should there be ANY oily residue on inlet or outlet side of charger?

    Or should it be completely dry and clean? Catch can is installed


  2. #2
    ecpChris's Avatar
    Join Date
    Jul 2007
    Location
    ocean county nj
    Posts
    2,912
    +1
    427
    Residue would be caused from the supercharger seal. Replace it with a Viton seal and it will prevent it from weeping

  3. #3
    dpracing's Avatar
    Join Date
    Jan 2008
    Location
    Palm Beach, Florida
    Posts
    1,244
    +1
    246
    Quote Originally Posted by ecpChris View Post
    Residue would be caused from the supercharger seal. Replace it with a Viton seal and it will prevent it from weeping
    It's a 2013 w 16 hours. Should it be weeping? Is that normal? Would it cause boost issues? Thanks

  4. #4
    ecpChris's Avatar
    Join Date
    Jul 2007
    Location
    ocean county nj
    Posts
    2,912
    +1
    427
    I've seen it happen randomly for no rhyme or reason. Doesn't matter about hours. It wouldn't cause the erratic boost you have been experiencing

  5. #5
    Quote Originally Posted by ecpChris View Post
    Residue would be caused from the supercharger seal. Replace it with a Viton seal and it will prevent it from weeping
    Mine still does that even after Jerry rebuilt my SC with Viton seal. Well, maybe not as mush as it used to

  6. #6
    Mothman's Avatar
    Join Date
    May 2011
    Location
    West Texas
    Posts
    2,999
    +1
    1,482
    I always have residue, but it never puddles in the ic. Occasionally I use brake cleaner and clean my ic. Quite a lot of gold-colored cleaner comes from the core...
    I always gain rpm the next time on the water. Not much, @100.

  7. #7
    dpracing's Avatar
    Join Date
    Jan 2008
    Location
    Palm Beach, Florida
    Posts
    1,244
    +1
    246
    Quote Originally Posted by Mothman View Post
    I always have residue, but it never puddles in the ic. Occasionally I use brake cleaner and clean my ic. Quite a lot of gold-colored cleaner comes from the core...
    I always gain rpm the next time on the water. Not much, @100.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 6
    Last Post: 06-02-2016, 10:35 PM
  2. Should there be liquid in filter
    By matsuka.vitaliy in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 03-04-2015, 08:45 PM
  3. Replies: 2
    Last Post: 08-25-2011, 10:33 PM
  4. Replies: 4
    Last Post: 06-20-2007, 07:09 PM
  5. ALL DONE. There is nothing better. Now on to the performance side.
    By jcorallo in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 04-22-2007, 09:26 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •