Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 29
  1. #1

    Exclamation Help to save my July 4th trip! My Ultra 250X leaks and stalls

    I am new to jet skis. I bought a used Ultra 250X as my first one. It's 2007 with a rebuilt motor, and 132 hrs. It worked fine when I took it out the first 3 times, and then the problems started:
    1) It used to get some water in the hull, but I was told it was normal. The last time it got too much water, the engine started choking around 3000-4000 RPM because of that. I took it to the shore and drained the water. The water was warm.
    2) It started to stall at different times, usually not in WOT. It would run for 20-60 seconds and then stop abruptly. The dashboard lights go out. It would restart if I push the key back and push the start button. I think it may or may not be related to the first problem, because it started before I had got too much water in the hull.

    I called 7 different repair shops in the Denver area today, and all of them are swamped until after 4ht of July. I planned a trip to a lake for the 4th of July. What can I do myself (I have no experience) to fix it at least for my upcoming holiday trip?

    I think I can:
    - change the spark plugs
    - dry it up, and hook it up to the garden hose and see if it leaks inside while running
    - maybe some other simple things

    Please advise, I would really appreciate if you help me to save my planned trip!


  2. #2

    Join Date
    Jun 2009
    Location
    Pleasant Grove, UT
    Posts
    225
    +1
    24
    You probably have a leaky exhaust... Especially if the water is warm. It's stalling because the hull is filling up with exhaust fumes and water from the exhaust instead of clean air. Back the trailer into the lake (or stick it on the hose) and start the ski and look into the hull. It should be obvious where it's coming from.

  3. #3
    devils ride 250's Avatar
    Join Date
    Mar 2010
    Location
    lehigh valley pa
    Posts
    775
    +1
    124
    Quote Originally Posted by sortsol View Post
    You probably have a leaky exhaust... Especially if the water is warm. It's stalling because the hull is filling up with exhaust fumes and water from the exhaust instead of clean air. Back the trailer into the lake (or stick it on the hose) and start the ski and look into the hull. It should be obvious where it's coming from.
    ya try that.

    U should t have hardly any water in there. Ive been out in heavy storms and taking water over the handle bars and at the end of the trip I have at MoST 1/2" of water in there. One time after pulling the engine bay apart to clean inter cooler and change super charger belt I didn't tight an clamp on exhaust and it spit water. Check those clamps. Plugs are easy to change. Use never seize and don't tighten past 13psi

  4. #4
    Thanks, I plan to run it with the garden hose asap. I also got the spark plugs, which was harder than I thought, b/c local auto shops don't know much about jet ski nuances. I got a set of NGK CR9EK and had to go back to buy another set of cheap plugs for the caps only. They sold me the anti-seize ointment, but I read that NGK doesn't need that. Will do what NGK said.

  5. #5
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,446
    +1
    650
    Spark plugs arent going to fix a water leak....My advise is to sell it, a 2007 Ultra 250 with a rebuilt motor already isnt a ski for a person new to PWC's............

  6. +1 by:


  7. #6
    devils ride 250's Avatar
    Join Date
    Mar 2010
    Location
    lehigh valley pa
    Posts
    775
    +1
    124
    U need the anti-sieze. And put electrical grease around the rubber grommets The problem is water can get in there and rust threads. It's a known issue.

  8. #7
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    07 kaw 250's have known issues that need updates.
    Do a search on here to find out the updates that have to he done to insure that it stays running.

  9. #8
    Quote Originally Posted by Aquaholic6801 View Post
    Spark plugs arent going to fix a water leak....My advise is to sell it, a 2007 Ultra 250 with a rebuilt motor already isnt a ski for a person new to PWC's............
    haha, I just bought it a month ago. The used jet ski market here is really tiny. I could not find a Honda, so I had to get what seemed to be ok and was available hoping that it would work out. I do realize that spark plugs cannot magically fix the leak, but I think it's a good idea to replace them anyway.

  10. #9

    Join Date
    Sep 2010
    Location
    Aliso Viejo
    Posts
    951
    +1
    75
    Even if it seems harsh but it is the truth. I guess he'll find out.
    Quote Originally Posted by Aquaholic6801 View Post
    Spark plugs arent going to fix a water leak....My advise is to sell it, a 2007 Ultra 250 with a rebuilt motor already isnt a ski for a person new to PWC's............

  11. #10

    Join Date
    Jun 2009
    Location
    Pleasant Grove, UT
    Posts
    225
    +1
    24
    So, you seem new to jetski's... Just a little hint, make sure you turn the jetski on before you turn the water on (but don't wait too long), and turn the water off before the jetski.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. need help!! I changed my stock 440 head and cylinders to a 550
    By js550rider in forum Kawasaki PWC Performance (2-stroke)
    Replies: 0
    Last Post: 06-30-2015, 08:43 AM
  2. I want to take my already awesome 15F and mod it to be better need help
    By buymyyam33 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 31
    Last Post: 10-05-2014, 07:12 AM
  3. Flipped my Ultra 250X over and got water in the engine
    By Derby in forum Kawasaki PWC Performance (4-stroke)
    Replies: 6
    Last Post: 06-15-2014, 03:46 AM
  4. I need help to fix my digital dash on my 2001 virage so i can sell it
    By ToriW88 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 07-02-2012, 09:18 PM
  5. rxp-x 2012 need help to solve my rpm problem
    By abdulla in forum 4-Tec Performance
    Replies: 9
    Last Post: 04-20-2012, 12:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •